Frage von patrickR23, 40

SVerweis mit zwei WENN Bedingungen liefert nicht das gewünschte Ergebnis?

Aktuell füllt sich der Wert in der Spalte so, dass entweder ein Wert bei D13 oder E13 eingetragen werden muss.

Wenn E13 nicht leer ist, aber einen Fehler (#NV) zurückgibt (da nichts findet), dann soll auf D13 geprüft werden.

Aktuelle Formel:

=WENN(ODER(E13<>"";0);WENN(ISTFEHLER(SVERWEIS(E13;Tabelle2!A:D;4;FALSCH));"");SVERWEIS(D13;Tabelle3!A:M;13;FALSCH))

Ich komm jedoch immer auf den Wert "0" raus oder leer und er greift dann nicht die zweite SVERWEIS Formel.

Jemand eine Idee?

Antwort
von Jackie251, 26

ich kann die Abfragelogik nicht nachvollziehen

Zunächstmal warum ist die erste Abfrage ein ODER, das jedoch nur eine einzige Prüfung durchführt. Der Zweite Teil ist fix mit 0 vorgegeben
ODER(E13<>"";0) wird daher immer das gleiche liefern wie
E13<>""

Als nächstest willst du gemäß deiner Beschreibung, dass in der 2. Tabelle gesucht wird, falls ist der ersten nichts gefunden wird.
Die Logikabfrage sollte demnach
Wennfehler(Tab1;Tab2) sein. Also falls die Auswertung nach Tab1 einen Fehler bringt, dann werte nach Tab 2 aus...
Deine Logik ist jedoch komplett unmgedreht.
Du nutzt eine Wennformel: Wenn (istfehler...; Dann nichts, sonst Tabelle 2)

Also WENN in Tabelle 1 etwas gefunden wird, dann ist dass KEIN fehler. Die Abfrage "Istfehler" führt also zu einen NEIN es liegt kein Fehler vor.
Das Nein führt nun dazu, dass Excel den ODER bereich der 2. Wennformel auswertet. Oder besser auswerten will, denn es gibt keinen Oderbereich.

Wenn hingegeben E13 leer bleibt, dann wird D13 mit tabelle 2 Ausgewertet.

Kommentar von Jackie251 ,

die beschriebene Aufgabenstellung kannst du so lösen

=WENN(E13="";"";WENNFEHLER(SVERWEIS(E13;Tabelle2!A:D;4;FALSCH);SVERWEIS(D13;Tabelle3!A:M;13;FALSCH)))
Kommentar von iMPerFekTioN ,

Oder so:

=WENN(ISTNV(E13);SVERWEIS(D13;Tabelle2!A:D;4;FALSCH);WENN(E13="";SVERWEIS(D13;Tabelle2!A:D;4;FALSCH);SVERWEIS(E13;Tabelle3A:M;13;FALSCH)))
Kommentar von patrickR23 ,

Hallo,
das funktioniert, allerdings wenn nun in E13 nichts eingetragen ist, dann verwendet er nicht den Wert aus D13.

Kommentar von Iamiam ,

zu Deinem letzten Einwand:

=Wenn(oder(E13<>"";D13<>"");Wennfehler(Wennfehler(SVerweis(E13;Tabelle2!A:D;4;FALSCH);SVerweis(D13;Tabelle3!A:M;13;FALSCH));"E und D prüfen!");"E UND D leer")

prüfen, weil nicht findbar

Antwort
von iMPerFekTioN, 21

Hallo,

ungetestet, da LibreOffice:

=WENN(ISTNV(E13);SVERWEIS(D13;Tabelle2!A:D;4;FALSCH);WENN(E13="";SVERWEIS(D13;Tabelle2!A:D;4;FALSCH);SVERWEIS(E13;Tabelle3A:M;13;FALSCH)))

Grüße,

iMPerFekTioN

Antwort
von LordSimcoe, 24

Druck ALT+F11 und programmier es dir in VBA. Geht viel problemloser.

Kommentar von Oubyi ,

Quatsch!

Antwort
von patrickR23, 17

Danke
=WENN(E13="";SVERWEIS(D13;Tabelle2!A:M;13;FALSCH);WENNFEHLER(SVERWEIS(E13;Tabelle3!A:D;4;FALSCH);SVERWEIS(D13;Tabelle2!A:M;13;FALSCH)))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten