Mit welcher Formel kann man sich den Wert einer Zelle zurückgeben lassen, die in der gleichen Zeile steht wie ein bestimmtes Wort?

... komplette Frage anzeigen

5 Antworten

Wegen der Formulierung "Wert schreiben": Excel-Formeln können nur den Wert beeinflussen für die Zelle, in der die Formel steht. Man kann nicht bspw. eine Formel in D1 erstellen, die dann einen Wert in H7 schreibt. Allerdings kann man den Inhalt von anderen Zellen als beliebig komplizierte Bedingung heranziehen, um den Wert für die Zelle zu bestimmen, in der die Formel steht

Wenn Du also willst, dass der Wert von D5 gem. der Bedingung wie von dir formuliert in Zelle A1 steht, musst Du in A1 schreiben:

=wenn(D3="Hotel";D5;0)

Antwort bewerten Vielen Dank für Deine Bewertung

Schau dir mal die WENN()-Funktion an :)

Antwort bewerten Vielen Dank für Deine Bewertung

Du gehst nach D5 und schreibst da rein 

=WENN(D3="HOTEL"; D3; "")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von noname68
24.02.2016, 11:05

wenn d3 leer oder nicht "hotel" ist, muss man das doch nicht erst programmieren. der TE hat sich irgenwie unglücklich ausgedrückt.

0
Kommentar von meinereiner100
24.02.2016, 11:23

Wenn (Dann; sonst)

D5  -   Wenn (in Feld D3 Hotel steht ; dann hole mir den Wert aus
Feld D3; sonst schreibe das was in den Anführungszeichen steht.

Also:  Wenn(D3="Hotel"; +D3;"0"

1

mit der "wenn" funktion kann du immer nur eine alternative programmieren, also eine entweder-oder aktion. "schreiben" von allein kann excel nicht.

wenn die bedingung "hotel" erfüllt ist, kannst du in der ziel-zelle einen wert oder auch einen text eintragen lassen. wenn aber dort schon etwas drin steht, wozu brauchst du dann eine abfrage-funktion, das sieht man doch auch so?

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn(D3="HOTEL";D5;0)

Antwort bewerten Vielen Dank für Deine Bewertung