SSH apt-get update funkt nicht?

... komplette Frage anzeigen

6 Antworten

Fehlermeldungen ist nicht immer zu glauben.
Wie auch den Fragen der Benutzer von gutefrage.net.
Unglücklicherweise hast du dann auch auch noch den Usernamen geschwärzt ( besser gebläut, wenn es so ein Wort gibt).

Das deutet darauf hin, dass du dich nicht als root ( der Superuser/Administrator bei Linux) angemeldet hast.

apt-get benötigt aber Superuser-Rechte.

Normalerweise meldet man sich als "normaler" User mit ssh an, wechselt mit su zum Superuser und führt solche Kommandos aus.

Sollte so ein Ubuntu die Zielmaschine sein, dann könnte man ( je nach User) auch mit sudo <Kommando>  das als Superuser ausführen.

Antwort bewerten Vielen Dank für Deine Bewertung

Steht ja da, was das Problem ist: Du hast einen mehrfachen Eintrag in einer Quelldatei (der Pfad zur Datei steht in der Fehlermeldung). Hat mit SSH übrigens nichts zu tun. :)

Antwort bewerten Vielen Dank für Deine Bewertung

Ich habe Debian und habe den server Neuinstalliert und wollte jetzt ganz normal updaten und upgraden

Antwort bewerten Vielen Dank für Deine Bewertung

Hast du an der sources Datei etwas geändert? Die scheint nicht ganz in Ordnung zu sein, lies dir mal die Fehlermeldung durch.

Antwort bewerten Vielen Dank für Deine Bewertung

Du bekommst  3 mal die Warnung, dass in der sources.list Einträge doppelt gelistet sind. Dein Betriebssystem ist der Meinung, dass diese Einträge durch aufruf von apt-get update gefixt werden könnten.

Wenn apt-get das nicht kann mach es doch selbst.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von barnim
24.07.2016, 18:31

ack. Duplikate aus der /etc/apt/sources.list (oder Dateien unter /etc/apt/sources.list.d/) sind zu entfernen, dann verschwindet die Warnung. Per se ist das aber kein wirkliches Problem, nur Optik.

cheers | barnim

0
Guten Tag

Auch einen schönen Tag.

unzwar ich habe folgendes problem nachdem ich apt-get update eingegeben 
habe kommt bei mir eine fehlermeldung die habe ich mit einem bild
eingeblendet

Mal sehen.

Nun zu der Frage was wolltest du machen?

Dass Betriebssystem Aktualisieren?

Hast du Ubuntu 16.04 oder Debian?

Antwort bewerten Vielen Dank für Deine Bewertung