Spaltenumbruch bei 2 Spalten, bei denen immer wieder Zellen eingefügt werden?

... komplette Frage anzeigen

1 Antwort

ICH würde ein zweites Tabellenblatt zum Ausdrucken nutzen:
Angenommen Deine Werte stehen in Tabelle1, Spalte A.
Dann in z.B. in Tabelle2!A1 Dies Formel:

=WENN(ZEILE(Tabelle1!A1)<=(ANZAHL2(Tabelle1!A:A))/2;Tabelle1!A1;"")

und in  Tabelle2!B1 diese Formel;

=INDEX(Tabelle1!A:A;ANZAHL2(Tabelle1!A:A)/2+ZEILE(A1))

und Tabelle2 für den Druck nutzen.
Wäre das eine Lösung für Dich?

P.S.: Voraussetzung ist, dass Spalte A lückenlos gefüllt ist, sonst geht das daneben. Dann müsste man noch mal "tricksen".
Teste auf jeden Fall genau, ob keine Werte verloren gehen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
24.06.2016, 18:33

Formeln, die auch bei Leerzellen funktionieren:
[Statt A:A besser A1:A1000 o.Ä., da sonst die Performance leidet]

A1: {=WENN(ZEILE(Tabelle1!A1)<=(MAX((Tabelle1!A:A<>"")*ZEILE(Tabelle1!A:A)))/2;Tabelle1!A1;"")}

B1:{=INDEX(Tabelle1!A:A;(MAX((Tabelle1!A:A<>"")*ZEILE(Tabelle1!A:A)))/2+ZEILE(A1))}

**ACHTUNG!** Das sind Matrixformeln.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formeln zu einer Matrixformeln.

0

Was möchtest Du wissen?