Frage von weisi88, 48

Sortierung von 2 Excel Tabellen mit Artikelnummern nach 2 Kriterien?

Hallo zusammen,

ich habe zwei Listen mit Artikelnummern. Die erste Tabelle (A) enthält 2500 Hersteller-Artikel mit Artikelnummern, welche ich aber nicht alle im Sortiment habe.

Die zweite Tabelle (B) enthält nur die Artikelnummer der in meinem Lager geführten Artikel (ca. 800).

Wie kann ich nun Tabelle A so sortieren, dass mir nur die Artikel inkl. Artikeldaten angezeigt werden welche ich auch wirklich im Lager habe?

Vielen Dank schon mal.

Beste Grüße,

Christian

Expertenantwort
von DeeDee07, Community-Experte für Excel, 38

Du könntest in Tabelle A eine Hilfsspalte anlegen mit der Formel (ausgehend, dass die Nummern in beiden Tabellen in Spalte A stehen, beginnend bei Zeile 2):

=ZÄHLENWENN(TabelleB!A:A;A2)

Diese Formel kopierst du nach unten. Wenn die Nummer gefunden wurde, steht eine 1, sonst eine 0. Jetzt kannst du die erweiterte Sortierung für mehrere Spalten verwenden.  https://support.office.com/de-de/article/Sortieren-von-Daten-in-einem-Bereich-od...

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 35

Mit der Funktion VERGLEICH oder besser ZÄHLENWENN kannst du in einer separaten Spalte herausfinden, ob ein Artikel im Lager ist.

Darauf setzt du dann einen Filter.

Kommentar von weisi88 ,

Super danke schon mal. Kannst Du das ein klein bisschen ausführen bitte.

Also ich habe Tabelle (A) mit 5 Spalten. Alle haben überschriften in der ersten Zeile. Die erste Spalte ist die mit den Artikelnummer, 2-5, die mit den Artikeldaten.

Habe jetzt Tabelle (B) in Tabelle (A) kopiert, welche ja nur die Artikelnummer meines Lagers enthalten. Tabelle (B) ist nun in Spalte 6.

Hilft Dir das?

Kommentar von Suboptimierer ,

Nee, du sollst nichts kopieren.

Du hast eine Tabelle mit 800 Lagerartikeln und eine mit 2500 Artikeln, von denen du die Lagerartikel angezeigt bekommen möchtest. Steht die Artikelnummer jeweis in der ersten Spalte, fügst du am Ende der Tabelle mit 2500 Artikeln folgende Formel ein:

=ZÄHLENWENN(A2;Lager!A2:A100000)>0

Die Spalte betitelst du mit "Ist Lagerartikel". Auf ähnlicher weise kannst du mit SUMMEWENN die Artikel zählen, also die Frage über die reine Existenz hinaus beantworten.

Kommentar von weisi88 ,

super besten dank hat geklappt :-)

Kommentar von Suboptimierer ,

Bitteschön!

Keine passende Antwort gefunden?

Fragen Sie die Community