Frage von Talkmaster, 162

sonntagsstunden berechnen excel?

Hi leute, folgende Frage!

Ich arbeite samstag auf Sonntag von 22:00- 03:00 Uhr und Sonntag dann von 20:00-03:00 Montag.

Wie addiere ich nur die Stunden zusammen die in den Sonntag einfließen?!

Danke dafür!

Expertenantwort
von Ninombre, Community-Experte für Excel, 162


In meinem Beispiel sieht die Datei so aus:
Spalte A = Datum (25.11.2015 usw)
Spalte B = Uhrzeit Arbeitsbeginn
Spalte C = Uhrzeit Arbeitsende
Spalte D wäre die Formel
=WENN(UND(WOCHENTAG(A2;1)=6;C2<B2);C2;WENN(WOCHENTAG(A2;1)=7;"24:00"-B2;""))

Als Erläuterung: Naheliegenderweise prüft Wochentag bei der ersten Bedingung, ob es ein Samstag ist. Wenn das Arbeitsende kleiner ist als der Beginn, wurde in den Sonntag hineingearbeitet-> also Sonntagsarbeit
Wenn der Wochentag ohnehin ein Sonntag ist, wird die Arbeitszeit ab Beginn bis 24h als Sonntagsarbeit gerechnet.

Kommentar von Britzcontrol ,

Kann es sein, dass sich da Fehler eingeschlichen haben?

Bei der Verwendung von "Wochentag Typ 1" ist der Sonntag = 1
Du prüfst den Freitag (6) statt den Samstag (7)
Bei nur Sonntagsarbeit gibt es keinen Sonntagsanteil

Bei mir funktioniertes mit:
=WENN(UND(WOCHENTAG(A2;1)=7;C2<B2);C2;WENN(UND(WOCHENTAG(A2;1)=1;C2<B2);"24:00"-B2;C2-B2))

Gruß aus Berlin

Kommentar von Ninombre ,

Oh, das ist in der Tat falsch... da müsste der Typ 2 rein,
=WENN(UND(WOCHENTAG(A2;2)=6;C2<B2);C2;WENN(WOCHENTAG(A2;2)=7;"24:00"-B2;""))
oder halt die Tage ändern wie von Dir gezeigt.

Kommentar von Iamiam ,

das ist genau der Grund, warum ich lieber mit Rest(Datum;7)=1 (für So) arbeite! Da gibts keine Typ-Verwechslungen, und ausserdem ist das ganze Wochenende <2.

Aber DH!

Antwort
von pn551, 145

Wäre es nicht einfacher, wenn Du Dir für die Sonntage eine separate Spalte machen würdest? Dann hättest Du die Wochentage seprat addiert und die Sonntage genau so. Und in der Waagerechten kann dann die Gesamtstundenzahl errechnet werden.

Kommentar von Talkmaster ,

nein,ichmöchte die stunden jasoeintragenwie sie auch sind..und mit separatensonntagen wäre das zuviel getippe.. mit einer einfach formel müsste ich nur die stunden eingeben..

Kommentar von pn551 ,

Wieso wäre das zuviel getippe? Wenn Du z. B. in Spalte A die Stunden der Wochentage einträgt und in Spalte B die Stunden der Sonntage,  dann brauchst Du doch nicht mehr tippen. Ob die Stunden in Spalte A oder in Spalte B stehen ist doch egal. Du mußt nur als Überschrift in A eintragen: Wochentage und in B als Überschrift Sonntage. Mit den separaten Sonntagen in einer anderen Spalte wäre es aber sehr übersichtlich.

Man kann es natürlich auch mit einer Formel machen, mit Excel kann man alles machen. Das müßte dann eine WENNdann-Formel sein.

Antwort
von Jackie251, 115

um die frage zu beantworten muss man erstmal wissen, wie die Daten vorliegen.

wie genau sind die beiden Arbeitesschichten denn eingetragen?

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten