Frage von mariusvon, 41

Selbstprogrammiertes Plugin, Console Error (Eclipse, Java 8 u66)?

Ich habe ein Selbstprogrammiertes plugin gemacht, dann kam folgender error in der konsole: org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:154) ~[spigot_server.jar:git-Spigot-db6de12-18fbb24] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [spigot_server.jar:git-Spigot-db6de12-18fbb24] at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot_server.jar:git-Spigot-db6de12-18fbb24] at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot_server.jar:git-Spigot-db6de12-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot_server.jar:git-Spigot-db6de12-18fbb24] at java.lang.Thread.run(Unknown Source) [?:1.8.0_66] Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml ... 6 more

Antwort
von Chaos53925, 41

Wie ich herauslesen kann fehlt entweder die plugin.yml in deiner jar datei oder sie kann nicht gelesen werden, da sie nicht im yaml format ist.

Antwort
von xDeron, 19

Wenn du Fehler erhälst schau am besten auf folgende Stelle:

"Caused by:"

Ich hatte denselben Fehler....

Vielleicht existiert die plugin.yml datei nicht oder hat ein falsches format.

Oder auch die plugin.yml ist fehlerhaft.

Schau am bessten auch nochmal nach, ob diese im src (source) Ordner steckt und guck ob 

Bei mir war sie fehlerhaft und das war der Fehler:

Die Abstände waren falsch.

Was ich damit meine mit den Leertasten bei "commands:" und "permissions:" usw.

Antwort
von CytoPcSupport, 14

Deine plugin.yml ist fehlerhaft.

Keine passende Antwort gefunden?

Fragen Sie die Community