Frage von hypergerd, 147

Schrift Helvetica unter Win7 vorhanden aber funktioniert nicht richtig?

Aufgefallen ist es auf Seiten wie Facebook (bin nicht angemeldet!), wo Umlaute mit dem Promille-Zeichen ‰ statt ä dargestellt werden.

Wenn man unter Internetoptionen\Allgemein\Barrierefreiheit "Schriftangaben auf Webseiten ignorieren" einstellt, werden die Umlaute richtig dargestellt, ABER ich möchte ja auch andere Schriftarten-Formen sehen.

Also untersuchte ich die Schrift Helvetica genauer.

  • c:\Windows\Fonts\Helvetica.ttf vorhanden
  • Systemsteuerung\Schriftarten NICHT vorhanden
  • Zeichentabelle: NICHT vorhanden
  • Word: in Kombobox vorhanden, ABER nach Anwahl springt er auf Times New Roman um????
  • Open Office: vorhanden
  • Registry: HKLM...Fonts\ findet man Helvetica Almindeling (True Type) Helvetica_0.ttf

Also Versuch der Neuinstallation: Doppelklick + Installation meldet "Helvetica Almindeling schon vorhanden". Auch wenn ich Drüberinstalliere -> dann entstand Helvetica_0.ttf -> ändert anber nichts.

Löschversuch der ttf Datei wird von Win7 selbst mit Admin-Rechten unterbunden.

In der Registry fand ich "Font Mapping" Helvetica = Arial ??? oder "FontSubstitutes" Helvetica = Arial ??? Nicht dass da was ersetzt wird. ABER in Arial habe ich richtige Umlaute... Gibt es außer Registry eine Möglichkeit zum Einstellungen für "Ersatz einer Schriftart"??

Also wie bekomme ich eine funktionierende Schriftart Helvetica hin, die:

  • in allen Programmen (Dialogen, Komboboxen) richtig angezeigt wird
  • die die Umlaute richtig darstellt

Zur Not würde ich auch eine Ersatz-Schriftart nehmen...

Bei einem anderen PC (auch Win7 64 Bit) ist unter OpenOffice kein Helvetica in der Kombobox und bei Facebook werden Umlaute richtig angezeigt.

ABER wie kann ich Helvetica deinstallieren? Unter Systemsteuerung\Schriftarten NICHT vorhanden! Aus Registry entfernen??

Antwort
von funcky49, 132

Du denkst zu kompliziert. Probiere folgendes im Internet Explorer:

Unter «Ansicht» die Option «Zeichenkodierung» oder
«Codierung» anklicken und hier «UTF-8» auswählen. Sollte die Anzeige der
Umlaute danach immer noch nicht stimmen, den letzten Schritt
wiederholen, aber auf «Westeuropäisch (Windows)» ausweichen.

Kommentar von hypergerd ,

Hatte ich alles schon probiert.

Bei Westeuropäisch (win) wird es noch schlimmer:

statt ä kommt √§

Kommentar von funcky49 ,

Dann würde ich mal den IE komplett zurücksetzen:


Internetoptionen - Registerkarte Erweitert- Zurücksetzen.

Auf Zurücksetzen klicken. Alles übernehmen, Rechner neu starten-

Kommentar von hypergerd ,

Andere Browser zeigen das auch...

Habe in Registry

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts

Helvetica Almindeling gelöscht

 -> nun OK

Kommentar von funcky49 ,

Na prima, da bist Du ja konsequent drangeblieben. Ich hätte nicht gedacht, dass es an dem Font liegt...

Keine passende Antwort gefunden?

Fragen Sie die Community