Frage von StephannahpetS, 24

Samsung X30 Linux Installations Probleme?

Hallo, Ich habe einen alten Samsung X30 Laptop mit Windows XP SP2 und würde gerne auf eine Linux Distribution wechseln. Deswegen habe ich geschaut welche für mich passen würde und bin auf Ubuntu Mate gestoßen. Nachdem ich die ISO auf einen verwendet habe um einen bootfähigen USB-Stick zu machen und ihn in den Laptop gesteckt habe bin ich auf das Problem gestoßen, das ich im BIOS nicht den USB Stick zuerst booten lassen kann. Daraufhin habe ich nach Lösungen gesucht und bin zu der Seite von "Plop Boot Manager" gekommen. Das hab ich mir heruntergeladen und auf eine CD gebrennt. Also beim nächsten Versuch bin ich in das Menü von dem Manager gekommen dort habe ich den USB-Stick ausgewählt und das Setup hat begonnen. Wie ich eben dann beginnen wollte zu installieren ist eine Fehlermeldung gekommen:

WARNING: PAE disabled. Use parameter 'forcepae' to enable at your own risk!

Nachdem ich das nachrecherchiert habe sieht es anscheinend so aus das der Prozessor eben etwas namens PAE braucht um das OS installieren zu können. (Was sich dann erst später herausstellt). Also habe ich gesucht wie man es enablen kann und habe dann dieses "forcepae" eingegeben wie es auf zahlreichen Foren beschrieben war. Danach schien es als würde es installieren jedoch wurde der Bildschirm schwarz, weiß und grau wie wenn er kaputt gegangen wäre. Da er in diesem Stadium verblieben ist habe ich ihn ausgeschalten und nochmal versucht --> Das selbe nochmal. Ich habe in Linux Kompatibiliätswebsites nachgeschaut ob der Laptop als unterstützt eingetragen war und fand ihn nirgends. Ich habe auch andere OS wie Linux Mint versucht wie exakt dasselbe passiert ist (forcepae, komischer Screen). Danach hab ich nach OS gesucht die kein PAE benötigen und das beste in dem Fall war AntiX. Also wiedereinmal ISO auf USB, gebootet, beim Installieren auf einmal weg und Bildschirmfehler. Sogar wie ich dann wie ich bemerkt hatte das die iso weniger als 700 MB groß war sie auf die CD gebrannt hatte (habe nur 700 MB CD's gefunden) ist genau dasselbe passiert. Deswegen Frage an euch hättet ihr eine Lösung?

Lg Stephan

Spezifikationen:

CPU: Intel Pentium M processor 1.7GHz (Code Name: Dothan?)

Mainboard: SX30S (Chipset: Intel i855PM) BIOS: Phoenix (Version 07UK)

RAM: 1GB DDR 1

Grafikkarte: Nvidea GeForce FX Go5200 32M/64M

Expertenantwort
von LemyDanger57, Community-Experte für Computer, Linux, Ubuntu, 16

Zu dem PAE-Problem hat Dir Newage ja schon ausführlich geantwortet, und im Prinzip hattest Du ja dazu schon alles richtig gemacht. Besser wäre natürlich eine Distribution, die kein PAE voraussetzt, das wird aber immer schwieriger, solche zu finden.

 Das Problem mit der Anzeige wird aber wohl eher am Grafiktreiber-Modul liegen. Du könntest mal versuchen, zusätzlich zum Parameter "Forcepae" noch den Parameter "nomodeset" mitzugeben.

Das "normale" Ubuntu (mit Unity-Oberfläche) wird allerdings auf dem Rechner nicht oder nur sehr schlecht laufen, ebenso wie Linux-Distributionen mit Gnome, KDE, Cinnamon oder MATE, die sind einfach zu ressourcenfressend. Besser wäre eine "schlanke" Oberfläche wie XFCE oder LXDE.

Hier mal eine Liste mit beonders für ältere PCs geeigneten Distributionen: http://distrowatch.com/search.php?ostype=All&category=Old+Computers&orig...

Vergiss ReactOS und KolibriOS, das sind erstens keine Linux-Distributionen, und zweitens sind die noch nicht über den Beta-Status hinausgekommen.

Ich findes es übrigens sehr löblich, dass Du erst mal selbst recherchiert und dies auch hier dokumentiert hast.

Kommentar von StephannahpetS ,

Danke für die Antwort, ich werde es mal versuchen und das mit der Grafikkarte hatte ich auch schon im Blick (nomodeset). Newage hat mir in seiner Antwort auch Xubuntu vorgeschlagen, welches jedoch die selbe Meldung mit "PAE diabled" gebracht hat. (Obwohl es ja kein PAE brauchen sollte) Aber es kann auch sein das ich mich verschaut habe und irgendeine falsche Version von Xubuntu genommen habe, da ich gestern in Eile war. Ich werde ich wieder ransetzten und informieren und mich bei weiteren Fragen melden! LG Stephan

Kommentar von LemyDanger57 ,

Wegen des PAE "Problems" könntest du es mal mit einer etwas älteren LTS-Version von Xubuntu versuchen, zum Beispiel mit der 14-04.5-i386, den Download findest Du hier: http://cdimage.ubuntu.com/xubuntu/releases/14.04.5/release/


Oder halt mit einer anderen Distribution aus der von mir gepostetetn  Liste von Distrowatch.

Antwort
von Neweage, 15

Lange Frage, dann gibt es auch eine lange Antwort (selber Schuld ;D)

Erstmal zu deinem Prozessor. Die M Serie hat PAE. Das Problem ist nur, das der Speicherkontroller das nicht mitteilt und es daher von der Seite des OS so aussieht als hätte die CPU keine PAE. 

Jetzt gibt es mehrere Möglichkeiten, wie du da drum herum kommst.
Die erste Möglichkeit wäre, dass du einen Desktop nimmst, der auf einem nicht-PAE Kernel basiert. Mein Favorit ist Xubuntu. Habe ich selbst auf einem etwas älteren Notebook. Der Xfce Desktop ist viel kleiner als Unity oder KDE, sieht schick aus und ist funktional. Da dein Rechner auch nicht mehr der jüngste/schnellste ist, würde ich dort nicht auf einen so großen Desktop wie Unity gehen.

Es gibt auch die Möglichkeit, das du eine Version von Ubuntu installierst die kein PAE "erwartet" und dann updatest. Dafür musst du die cpuinfo "fälschen" damit Ubuntu nicht merkt, das PAE "offiziell" nicht unterstützt wird.

Es gibt dann noch ein paar andere Möglichkeiten, alle in dem Beitrag beschrieben, den ich unten eingefügt habe.

Ich persönlich würde Xubuntu oder eine andere Distro mit Xfce Desktop nehmen. Ist auf den alten PC auch schneller und du kannst es dir ja mal im Live-Modus ansehen.

Hier der Link zum Beitrag:

https://askubuntu.com/questions/117744/how-can-i-install-on-a-non-pae-cpu-error-...

Schönen Gruß und viel Erfolg,
Neweage

Kommentar von StephannahpetS ,

Ich werde es mal mi Xubuntu versuchen falls wieder diese Anzeigefehler auftreten komm ich auf dich zurück. Danke für die Antwort

Keine passende Antwort gefunden?

Fragen Sie die Community