Frage von magicmanman, 129

Saitek X52 Pro-Treiber funktioniert nicht, was kann ich tun?

Hallo liebe Community, ich habe mir das oben genannte hotas-System gekauft und versuche es nun verzweifelt zum laufen zu kriegen. Soweit ich das beurteilen kann ist vom mechanischen her alles in Ordnung, das Problem liegt an der Software und die macht mich wahnsinnig!

Das Hauptproblem besteht darin, dass wenn ich den Treiber auf der Hersteller-Seite downloade und ausführe, nichts weiter passiert. Ich starte die Software (der Stick ist noch nicht eingesteckt), irgendwann fordert er mich auf den x52 pro einzustecken, das tue ich auch und joa, weiter passiert nichts.

Der grüne Ladebalken läuft eine lange Zeit (5-10 min.), stoppt irgendwann und nichts geschieht. Habe die Treiber etliche Male de- und neuinstalliert, hilft nicht. Ich habe stundenlang im Netz nach Lösungen gesucht und teilweise auch Hilfevorschläge gefunden aber nichts hat etwas gebracht.

Ich habe beispielsweise alle Treiberdateien deinstalliert, Ordner und Dateien auf der C-Platte gelöscht, ich war sogar im regedit und habe nach Anleitung spezifische Dateien gelöscht, ich habe ältere Versionen der Treiber installiert, Reihenfolgen durchprobiert, das Internet während der installation gekappt, USB-Ports gewechselt (sowohl 2.0 als auch 3.0), ich habe auch versucht den Treiber des Vorgängers (x52) zu installieren aber es bringt alles nichts.

Ich habe mir den x52 pro für Elite Dangerous gekauft (Steam) und habe versucht den Stick ohne Treiber zu starten, da Windows den Stick zumindest erkennt und ich dachte vllt. gehts auch so, aber Pustekuchen! Wenn der Stick vor dem Start von ED steckt, startet das Spiel einfach nicht und wenn ich Ihn, nachdem ich das Spiel gestartet habe, anschließe, friert es ein und Windows reagiert auf viele Befehle nicht mehr (muss den Pc dann auf die unschöne Art neustarten).

Das ist ohnehin so ein Punkt, den Stick kann ich erst mit dem Pc verbinden nachdem er gebootet hat, starte ich den Rechner während der x52 pro in nem USB-Port steckt, geht das Bildsignal noch vor dem Homescreen verloren, kann den x52 pro also erst nach dem Start des Pc's einstecken, ziehe ich Ihn dann während des Betriebs, spinnt Alles rum und reagiert sehr langsam, wenn überhaupt.

Hier einmal meine System:

Betriebssystem: Win7 Ultimate 64bit

CPU: Intel i7 4790K @4 Ghz

GPU: GTX 980

RAM: 8gb @2133 Mhz

Mir gehen die Ideen aus... ich hoffe Jemand kann mir helfen, da ich ansonsten gezwungen bin das Ding zurück zu schicken, was ich echt schade fände. In jedem Fall schon mal danke für Antworten.

MfG
Magicmanman

Antwort
von Attacktic, 109

Hört sich so an, als hätte Windows einen weg... Vielleicht mal neuinstallieren... Kann aber auch sein, das der Stick oder die Schubkontrolle einen weg hat...

Hier noch mal die Treiber und die Software, weiss nicht ob du den link benutzt hast: http://www.saitek.com/uk/down/drivers.php

Allerdings hört es sich wirklich so an, als hätte dein Windows einen weg...

Wünsche dir viel Glück.

Kommentar von magicmanman ,

Mein Windows lief bislang bestens, falls es mal Probleme gab, ließen die sich schnell beheben und solange der x52 pro nicht angeschlossen ist läuft mein Pc wie gewohnt, aber bei dem Treiber des H.O.T.A.S' scheint wirklich grundlegend was schief zu laufen (und ja genau auf der Seite war ich). Es ist auch ein verbreitetes Problem, dass die Treiber bei vielen einfach nicht laufen, naja mal sehen, trotzdem erst mal vielen Dank.

Kommentar von Attacktic ,

Wieviel hat denn das Ding gekostet? Vielleicht zurück geben und dafür noch mal eine Schippe drauf legen und was besseres holen...

https://www.alternate.de/Thrustmaster/Hotas-Warthog-Joystick/html/product/695922...

Den habe ich. Hatte noch nie Probleme damit und ist noch nicht mal ein Plastikkasten.

Gruß Attacktic

Kommentar von magicmanman ,

160€ hat's mich gekostet, habe auch schon überlegt mir den Warthog zu holen, allerdings kostet der das Doppelte, zusätzlich bräuchte ich wahrscheinlich Ruderpaddels da der Warthog kein YAW hat, und spätestens ab dem Punkt wär ich raus.

Kommentar von Attacktic ,

Klar ist der Schweineteuer... Die Rotationsachse könntest du allerdings auch auf ein anderes Pad legen... ich habe ihn beispielsweise auf dem Trimmpad bei Helis.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten