Frage von Max0981, 29

Ruby Shoes richtig installieren?

Wie kann ich das GUI-Framework, Shoes für Ruby so installieren das ich einfach nur noch eine TXT öffnen muss, Shoes-Code reinschreiben kann, abspeichern, und es dann einfach mit einer CMD oder so ausführen kann. (Also so das CMD oder so den Shoes-Code wirklich anerkennt und dann z.b. ein Fenster öffnet.)

Antwort
von nilsding, 24

normalerweise reicht es, wenn du Shoes über Rubygems mit `gem install shoes` installierst (bei JRuby musst du iirc jgem verwenden) und dann deinen Code als ausführbare .rb-Datei abspeicherst.  Am Anfang der Datei sollte folgende Zeile stehen:


#!/usr/bin/env ruby


Auf unixoiden Systemen (z.B. OS X, BSD) startet deine Shell dann beim Aufruf der Datei den Ruby-Interpreter.

Vergiss nicht, nach der Installation des Rubygems auch noch Shoes zu `require`n.

Kommentar von Max0981 ,

Wenn ich Shoes per gem installiere und ich dann require 'shoes' oben hinschreibe und halt noch irgendeinen Shoes Code dann spuckt er mir folgendes aus:

Sorry, this gem currently does nothing. Team Shoes is working on Gemifying Shoes, and this is just a placeholder until then.

Da steht also das Shoes erst daran arbeitet und dieser gem nur ein Platzhalter ist. Gibt es keine andere möglichkeit ?

(Ich hab übrigens Windows 10, kann es daran liegen?)

Kommentar von nilsding ,

Oh, Shoes ist immer noch nicht fertig.

Auf dem Github-Repo steht beschrieben, wie man Shoes4 installiert, auch auf Windows.

https://github.com/shoes/shoes4#installing-shoes-4-as-a-gem

Kommentar von Max0981 ,

Ach ich warte einfach auf die gem Version von Shoes. Das ist mir da zu kompliziert auf der Seite

Keine passende Antwort gefunden?

Fragen Sie die Community