Robot Karol dringende Frage?

... komplette Frage anzeigen

1 Antwort

Am Ende der Welt? Robot Karol kann nur abfragen ob er vor Wände, Marken oder Ziegel steht oder nicht.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von lop77
25.04.2016, 15:34

also folgendes habe ich in robot karol schon aber jetzt will ich das wenn er dann wieder nach norden geht, das er jetzt nach rechts geht.

wiederhole solange nicht istnorden
linksdrehen
*wiederhole
wiederhole solange nicht istwand
schritt
*wiederhole
linksdrehen
wiederhole solange nicht istwand
schritt
*wiederhole
linksdrehen

wiederhole solange nicht istwand
schritt
wenn istziegel
dann
aufheben
*wenn
wenn istwand
dann
linksdrehen
schritt
linksdrehen
wenn istwand
dann
rechtsdrehen
schritt
rechtsdrehen
*wenn
*wenn

*wiederhole

0