Frage von hallobirne123, 23

RGB Stripe funktioniert nicht richtig?

Ich habe einen WS2812B RGB Stripe mit 144 RGB Led's. Wenn ich 5 Volt anschließe, leuchtet nur eine LED in der Mitte ganz hell und eine LED am ende vom Strip. Woran kann das liegen?

Antwort
von W00dp3ckr, 21

1. Schau Dir die Schaltungsanleitung ganz genau an. Irgendwo wollte das Teil noch einen Widerstand und einen Kondensator haben.

2. Wenn Du den Streifen nicht initialisierst, dann dürften die Helligkeitswerte eher zufällig sein.

Kommentar von hallobirne123 ,

Vielen Dank, was ist denn initialisieren?

Kommentar von W00dp3ckr ,

Hast Du den einfach so angeschaltet, oder gibt es irgendwo Elektronik die mit dem Streifen spricht?

Kommentar von hallobirne123 ,

ich habe die 3 Kabel mit einem Arduino Uno verbunden

Kommentar von W00dp3ckr ,

Ja, aber der ist doch nicht plug und play. Du musst dann schon ein Programm schreiben, das die Farben setzt. Hast Du das?

Ferner ist die Frage, wie hast Du den Streifen verbunden? Kann der Arduino überhaupt so viele LEDs treiben? Oder hast Du ein zusätzliches Netzgerät?

Kommentar von hallobirne123 ,

Ich habe ein programm von Adafruit für WS2812B Leds und habe ein externes netzteil 5 Volt

Kommentar von W00dp3ckr ,

Woran hängt das Netzteil? Wieviel A kann das treiben?

Kommentar von hallobirne123 ,

Das Netzteil hängt an der Steckdose und kann 2.0 A leisten

Kommentar von W00dp3ckr ,

1. Das wird wohl kaum reichen. Mach mal die Summe, wieviel die einzelnen Dioden brauchen.

2. Wie hast Du das Netzteil verschaltet? Du kannst nicht einfach die 5V Pins von Deinem Arduino nehmen und damit den ganzen Streifen treiben.

Entschuldigung, wenn Du das alles schon weißt, aber sicher ist sicher.

Kommentar von hallobirne123 ,

Die Led's verbrauchen 34 Watt

Kommentar von W00dp3ckr ,

2.0A sind aber 10 Watt.

Und wie das Netzgerät an den LED-Streifen bzw. Arduino angeschlossen ist, das hast Du auch noch nicht verraten.

Keine passende Antwort gefunden?

Fragen Sie die Community