Frage von Schrotti2002, 110

RaspberryPi-SSH-Server funktioniert nicht - könnt Ihr mir helfen?

Hi Community, da ich mich mit dem RaspberryPi (und linux) noch nicht so viel beschäftigt habe, habe ich eine Frage an euch! Ich habe bei mir zu Hause einen RaspberryPi stehen, der bisher als SSH-Server am Netz hing (Damit meine ich, dass er auch von außen erreichbar war!). Nun musste es ja irgendwann soweit kommen, dass ich den RaspberryPi neu aufsetzen durfte, citadel-server hust hust. Somit waren alle meine Daten weg, und ich konnte nochmal von vorne anfangen! Also den NOIP-Client installiert, Portfreigaben eingerichtet und, und, und...

Als ich dann aber versuchte mich von einem neuen Netzwerk unter meiner Domäne anzumelden, hatte ich einen ConnectionTimeout! (Im lokalen Netzwerk war es (auch unter meiner Domäne) genau das gleiche) Ich habe probiert und probiert, doch bin zu keiner Lösung gekommen! Hoffe ihr könnt mir helfen, MfG Schrotti

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von franzhartwig, 54

waren alle meine Daten weg, und ich konnte nochmal von vorne anfangen!

Triviale Sache: Backups helfen. Und zwar nicht nur vom home-Verzeichnis, sondern auch von /etc. Dann musst Du nur die Pakete neu installieren, spielst das Backup zurück, startest die Dienste neu und alles ist wie vorher. Wenn Citadel (oder eine andere Anwendung auf dem Pi) eine Datenbank verwendet, musst Du die natürlich auch sichern (bei MySQL ist das /var/lib/mysql).

Als ich dann aber versuchte mich von einem neuen Netzwerk unter
meiner Domäne anzumelden, hatte ich einen ConnectionTimeout! (Im lokalen
Netzwerk war es (auch unter meiner Domäne) genau das gleiche)

Also ist es egal, ob Du aus dem lokalen Netzwerk oder über das Internet kommst? Dann mache erst einmal alle Tests vom lokalen Netzwerk, um die Fehlerquelle no-ip etc. auszuschließen. Du hast mit ifconfig die IP-Adresse kontrolliert? Die ist per Ping erreichbar? Dann mache mal ein

 sudo service ssh status

Da sollte das herauskommen:

[ ok ] sshd is running.

Wenn nicht, hilft ein

sudo service ssh start

Wenn eine Fehlermeldung kommt, musst Du die erst einmal sinnentnehmend lesen und ggf. in die Logs schauen. Wenn der Server lokal erreichbar ist, dann probiere es über das Internet.

Kommentar von Schrotti2002 ,

Danke für den sehr hilfreichen kommentar, aber das Problem hat sich durch

sudo service ssh restart

von selbst gelöst ;-)

Der Citadel-Server lief übrigends nur im lokalen Netzwerk, und auch nur zu experimentellenn zwecken!

MfG Schr0tti

PS: Der SSH-Dienst war schon angeschaltet, musste aber wegen "HIER BITTE BEGRÜNDUNG EINFÜGEN" neu gestartet werden!

Antwort
von Manuauto, 71

Der häufigste Fehler: Hast du die richtige IP Adresse?

Kommentar von Schrotti2002 ,

denke schon!

Kommentar von Manuauto ,

Ping 192.168.x.xx

Kommentar von Schrotti2002 ,

4 gesendet, 4 empfangen, 22 Millisekunden Durchschnittswert!

Kommentar von Manuauto ,

Ja offensichtlich schon

Antwort
von Fregrin, 47

Wenn Ping geht: läuft der SSH Dienst überhaupt?
http://raspberrypiguide.de/howtos/ssh-zugriff-unter-raspbian-einrichten/

Keine passende Antwort gefunden?

Fragen Sie die Community