Frage von tosmile01, 96

Portfreigegeben aber ist dennoch nicht erreichbar?

Guten Tag,

Ich habe ein kleines Problem. Ich habe den Port (80) für meine Webseite (auf dem Raspberry PI) freigegeben. wenn ich aber die Webseite aufrufen möchte. reagiert sie nicht und bei dem Port-check steht der Port sei geschlossen. -.-

Also ich habe folgendes eingegeben.

IP: 192.168.x.xxx (IP von meinem Raspberry)
Port: 80 (webport)
Protokoll: TCP
Zielport: 80

PS. auf dem Raspberry PI läuft ein Apache2 Webserver und wordpress. Die darauf gebundene Domain ist von hosttech.ch

LG tosmile

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von netzy, Community-Experte für Computer & Internet, 32

du versuchst den Aufruf aber schon mit einem Rechner, der NICHT in deinem Netzwerk zu Hause ist und gibst dazu die öffentliche IP deines Routers ein ?

oder auch aus einem Mobil-Netz vom Handy.......

Kommentar von tosmile01 ,

Ja natürlich

Kommentar von netzy ,

Wenn ich die IP (ipaddresse.de) von einem Anderen Rechner nehme komme ich auf die Webseite von meinem PI. Aber eigentlich sollte ich doch auf den Router kommen.


Und die Portweiterleitung funktioniert immer noch nicht.



dann widersprichst du dir aber selbst ;)

"von einem anderen Rechner" kannst du keine IP-Adresse nehmen, du hast nur eine WAN-IP (ipadresse.de), die Rechner haben eine LAN-IP

mit deiner WAN-IP (von einem Rechner Außerhalb aufgrufen) kommst du auf die Webseite des PI........... (deine Aussage)

und was stört dich jetzt daran ??????????
genau das willst du doch :-)

und damit muß ja auch die Portweiterleitung zum PI funktionieren, wie solltest du denn sonst von Extern hinkommen :-)

Kommentar von tosmile01 ,

Huuch.. Danke ^^ hatte gerade einen üblen Denkfehler.

Kommentar von netzy ,

biddesehr ;)

Antwort
von flaglich, 61

Noch ne dumme Frage: wo hast du das Zitat eingegeben?

nebenbei: Private IP dürfen bei so einer Frage ausgeschrieben werden, nur mit normalen IP sollte man vorsichtig sein.

Expertenantwort
von SYSCrashTV, Community-Experte für Computer & Internet, 26

Sofern du die Webpage über die lokale IP öffnen kannst ist sie ja schon einmal aktiv. Möglich ist es, dass dein Router das sog. Hairpinning nicht kann und somit nicht von seinem lokalen Netz heraus eine Anfrage auf seine eigene öffentliche IP auflösen kann. Daher musst du es z.B. mit dem Handy außerhalb deines WLANs testen.

Antwort
von softie1962, 49

Schau mal in der httpd.conf nach dem Listen Eintrag.

Standardmäßig steht da beim Apache localhost:80

Der Server hört also nur auf Anfragen vom eigenen Rechner

Lösche also das localhost samt Doppelpunkt und starte den Apache neu


Kommentar von tosmile01 ,

er läuft auf Port 80

Kommentar von softie1962 ,

Also steht in der Zeile nur

Listen 80

Oder steht vor der 80 noch irgendwas?

Kommentar von tosmile01 ,
# If you just change the port or add more ports here, you
will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default.conf

Listen 80
<IfModule ssl_module>
     Listen 443
</IfModule>
<IfModule mod_gnutls.c>
Listen 443
</IfModule>
# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Kommentar von softie1962 ,

Ist die Webseite von einem anderen Rechner im gleichen Netz erreichbar?

Kommentar von tosmile01 ,

Ja, Problemlos

Kommentar von tosmile01 ,

Ich starte mal meinen Router neu vill. hat der ein Fehler oder sonst was.. hmm..

Kommentar von softie1962 ,

könnte helfen.

Was passiert denn, wenn du im Browser als Adresse
http://<deine internet ip adresse>
eingibts?

Die bekommst du raus, wenn du auf ipadresse.de gehst

Kommentar von tosmile01 ,

Hmm interestant... ich werde auf meine Webseite weitergeleitet..

Aber nicht mit der IP von Raspberry PI sondern mit der IP von meinem Normalen Computer o.O

normalerweise sollte ich ja auf meinen Router kommen

Kommentar von softie1962 ,

Meinst du jetzt die lokale IP von deinem normalen Computer?

Kommentar von tosmile01 ,

Nein wenn ich die von ipadresse.de eintrage

Kommentar von softie1962 ,

Also funktioniert die Portweiterleitung einwandfrei.
Jetzt fehlt dir wahrscheinlich ein Domainname unter der du die Webseite erreichen möchtest?

Kommentar von tosmile01 ,

Was .. nein... Wenn ich die IP (ipaddresse.de) von einem Anderen Rechner nehme komme ich auf die Webseite von meinem PI. Aber eigentlich sollte ich doch auf den Router kommen.

Und die Portweiterleitung funktioniert immer noch nicht.

Kommentar von deruser1973 ,

Auf den Router kommst du mit der Standardgateway IP... denn das Gateway ist der Router...

Es gibt ein recht gutes Tool namens "Fing" für Android,  das dir alle IPs im selben Wlan anzeigt,  das hat mir schon oft geholfen...

Antwort
von SergeantPinpack, 43

(Vielleicht) Dumme Frage: dass der Adressraum innerhalb 192.168.0.0/16 privat ist und daher nicht aus dem Internet erreichbar, ist dir bewusst, oder?


Kommentar von tosmile01 ,

Ehmm.. können Sie das genauer beschreiben? ^^

Kommentar von SergeantPinpack ,

Siehe https://de.wikipedia.org/wiki/Private\_IP-Adresse.
>

Damit der Raspi (ich gehe jetzt einfach mal davon aus, dass er "zu Hause" steht) aus dem Internet erreichbar ist, muss am Router ein entsprechendes Port-Forwarding konfiguriert sein.

Nachtrag: und auch in diesem Fall wäre er im Internet nur unter der externen Adresse erreichbar.

Kommentar von softie1962 ,

Ich denke mal der Eintrag ist auch nur die Portweiterleitung im Router und müsste so eigentlich richtig sein, weil die Anfragen von aussen auf Port 80 ja an die lokale IP des Raspi weitergeleitet werden sollen.

Kommentar von SergeantPinpack ,

... das gilt es ja erst noch herauszufinden. Ich habe mir bei Ferndiagnosen angewöhnt, zunächst ein mal die offensichtlichsten Punkte zu hinterfragen.

Kommentar von tosmile01 ,

Es tut mir leid aber so viel ich weiss sind die bei unserem Anbieter (swisscom) durch einen Port zu öffnen und somit. Ja sind sie.

Es hat eig. schon immer funktioniert.. nur diesmal nicht

Keine passende Antwort gefunden?

Fragen Sie die Community