Frage von SYSCrashTV, 138

Ping funktioniert nicht bei Hostnamen, Nslookup aber schon?

Hallo, ich habe folgendes Problem:

Ich kann in meinem Heimnetzwerk (unter Windows) nur Geräte pingen wenn sie NetBIOS haben oder sie in meiner HOSTS-Datei sind. Mein Handy zum Beispiel ist unter dem Hostnamen "MaxS4" im Netzwerk. Das merkwürdige ist, dass es unter Windows mit dem Befehl "nslookup" funktioniert, dort bekomme ich von MaxS4 die IP 10.20.1.2, aber beim Ping-Befehl kann der MaxS4 nicht auflösen. Auch im Browser kann ich mein Handy so nicht aufrufen, da er dort den DNS-Namen nicht findet. Über die IP funktioniert es.

Dasselbe bei unserem Router. Diesen kann ich nur aufrufen wenn der Hostname einen Punkt enthält also Max.EasyBox funktioniert EasyBox als solches wieder nur mit nslookup aber halt nicht im Browser. Meinen Geräten im Netz kann ich leider keinen "." in den Namen setzen da unsere Box dann aus Max.Laptop nur Max macht. Wie kann ich das beheben?

Bei Geräten mit NETBIOS geht es, aber mein Handy hat das z.B. nicht und so muss ich immer die IP eintippen und der Hostname funktioniert nicht.

Da ich neben meinem Hausnetzwerk auch noch in anderen Netzen bin ist das mit den Hostnamen immer sehr komfortabel gewesen da ich in jedem Netz nur "MaxS4" eingeben musste und nicht die IP heraussuchen muss!

Auch ist das nur in unserem Netz, bei einem Freund funktioniert das auch im Browser... An was kann das liegen?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von franzhartwig, 120

Die Easy-Box spielt DNS-Server. Sie scheint eine Domänen-Namen zu vergeben. Probiere mal bitte MaxS4.easybox aus.

Kommentar von SYSCrashTV ,

Mit einem Domänennamen habe ich es auch schon versucht, in der EasyBox-Konfig ist aber keiner Eingestellt und selbst wenn ich einen einstelle funktioniert es nicht.

Kommentar von franzhartwig ,

Ich meinte nicht, dass Du die Easybox umkonfigurierst. Ich meinte, dass Du mal ping MaxS4.easybox ausprobieren sollst.

Kommentar von SYSCrashTV ,

Das habe ich, mit und ohne konfigurierte Domäne funktioniert es nicht. Ich werde mal schauen ob ich eine FritzBox bekomme, da nun die Fernverwaltung der EasyBox nicht mehr funktioniert, wegen dem DH-Key...

Antwort
von Brot454, 109

Am DNS Server, er löst nicht richtig auf. Versuch mal den Server neuzustarten.

Kommentar von SYSCrashTV ,

Das bringt leider nichts da das Problem schon seit Anfang an besteht. Am Anfang habe ich immer mit den IPs als solche gearbeitet aber das wird mittlerweile zu unübersichtlich... Daher hab ich das versucht und am Anfang als "normal" abgetan. Auch hab ich die Box mal neu eingerichtet auch danach funktioniert es nicht.

Kommentar von Brot454 ,

Aber es ist normal das du einen Punkt machen musst. Das Brauch er, also versuch es mal *.easybox dein DNS Server heißt in dem Fall easybox

Keine passende Antwort gefunden?

Fragen Sie die Community