OpenOffice CalcExperte benötigt?

... komplette Frage anzeigen

2 Antworten

=Summewenn(A:A;"A";D:D)/Zählenwenn(A:A;"A")

Vllt gibt es sogar MittelwertWenn, schau mal nach.

Die neuesten Versionen von LO akzeptieren die Schreibweise A:A, bei älteren musst Du zB A$1:A$999 schreiben, ebenso in OO (ich würde Dir ohnehin LibreOffice empfehlen, das wird besser gewartet, ist ja ebenfalls kostenlos).

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
14.08.2016, 08:57

Ja, es gibt auch MITTELWERTWENN(S).
Die Formel wäre dann

=MITTELWERTWENN(A:A;"A";D:D)

Bzw. in OO ohne ganze Spalten:

=MITTELWERTWENN(A1:A999;"A";D1:D999)


1

Du kannst auch den Quotienten der (Quasi-Matrix-)Formeln

=SUMMENPRODUKT((A2:A999="A")*D2:D999)/SUMMENPRODUKT((A2:A999="A")*1)

verwenden. Diese Formel kann manchmel sinnvoll sein, hier ist sie länger als Summewenn/Zählenwenn oder gar Mittelwertwenn

Die beiden Bereiche müssen aber exakt die gleiche Zellenzahl umfassen und der Bereich D2:D999 darf nur Zahlen (oder leere Zellen) enthalten!

(nur wg des Prinzips erwähnt: auch ein Datum wäre eine Zahl, aber das macht ja hier keinen Sinn)

Die Einführung von A:A ist offensichtlich noch nicht fertig, in obiger Formel funktioniert das noch nicht!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von DeeDee07
14.08.2016, 19:05

DH!

Bei mir (LO-Version 5.0.5.2) funktioniert deine Summenprodukt-Formel auch mit A:A ganz gut.

Dabei habe ich zufällig entdeckt, dass LO bei der Prüfung von Texten Case-sensitiv ist, im Gegensatz zu Excel.

Formel: ="A"="a"
Excel: WAHR
LO: FALSCH

1

Was möchtest Du wissen?