Frage von bakayaro74, 37

open Office wenn-dann Funktion im sonst wert soll text UND Rechnung stehen?

hey leute, in Informatik haben wir eine aufgabe gestellt bekommen. in dieser sthet dass mehrere schüler verschiedene Praktika habne . wenn die gesamt zahl der absolvierten Wochen über 52 ist soll "ja" stehen. wenn es nicht erfüllt ist soll stehen:"nein es fehlen ... wochen". mein Problem ist, dass bei ... die anzahl der fehlenden Wochen stehen soll also =52-summe Praktika Wochen.

ich hab`s versucht nicht geschafft und nun wende ich mich an euch. vielen dank im vorraus

Antwort
von Oubyi, 24

Angenommen die Summe der absolvierten Wochen steht in A1, dann diese Formel:

=WENN(A1>52;"ja";"nein es fehlen "&53-A1&" Wochen")

Allerdings steht dann bei EINER fehlenden Woche auch:
"nein es fehlen 1 Wochen"
Wenn Du DAS noch abfangen musst, sag Bescheid.

P.S.: Ich habe "nur" Excel und bin nicht sicher, dass OO das "&" als Operator versteht. Falls nicht versuche mal diese Formel:

=WENN(A1>52;"ja";VERKETTEN("nein es fehlen ";53-A1;" Wochen"))

Kommentar von bakayaro74 ,

nein das ist egal
danke

Kommentar von Oubyi ,

Gern geschehen ☼

Antwort
von SirToastaire, 25

Zunächst: meinst du den Open Office-Excel-Verschnitt? 

Dann =Wenn((hier Feld mit der absolvierten Wochen)>=52;"JA!!!!";"Nein es fehlen wochen")

Kommentar von bakayaro74 ,

das habe ich schon. aber soll ja stehen nein es fehlen (52 - summe der wochen)wochen

Kommentar von SirToastaire ,

Sorry, bei dem Problem kann ich nicht helfen. Es ist länger her, dass ich Excel benutzt habe.

Keine passende Antwort gefunden?

Fragen Sie die Community