Frage von EtBap, 63

Mit welcher Formel zält man die Anzahl von Einträgen einer Liste OHNE Duplikate?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 47

Eine einzige Formel kann ich dir gerade nicht nennen. Das Problem kannst du aber mit einer Hilfsspalte lösen.

Meine Testwerte sind in A11:A17. In B11 schreibe ich eine 1, in B12:

=B11+ISTNV(VERGLEICH(A12;$A$11:A11;0))

und ziehe diese Formel herunter.

In der untersten Zelle von Spalte B steht die Anzahl an Einträgen ohne Duplikate aus Spalte A.

Antwort
von dkilli, 14

Diese Formel ist besser

=SUMME(WENN(A1:A100<>"";1/ZÄHLENWENN(A1:A100;A1:A100)))

Diese Formel auch als Matrixformel speichern. Also mit Strg + Shift + Enter abschließen.

Gegenüber meiner ersten Formel kann man Zeilen einfügen.Den Bereich von A1:A100 kannst du deinen Wünschen entsprechend anpassen.

Antwort
von nedi23, 42

Ich glaube dies könnte dich interessieren:

http://www.herber.de/forum/archiv/292to296/294514_doppelte_Werte_nur_einmal_zaeh...

Antwort
von dkilli, 42

Sind in der Liste nur Zahlen oder Zeichen?

Welches Excel hast du?

Kommentar von EtBap ,

Zeichen. Die neueste Version.

Kommentar von dkilli ,

In Spalte A sind die Daten. In einer anderen Zelle folgendes eingeben:

=SUMME((VERGLEICH(A:A&"";A:A&"";0)=ZEILE(A:A))*1)-1

Dies aber nicht mit Enter abschließen, sondern es ist eine Matrixformel. Die muss mit Strg + Shift + Enter abgeschlossen werden! 

Dann steht:

{=SUMME((VERGLEICH(A:A&"";A:A&"";0)=ZEILE(A:A))*1)-1}

Die geschweiften Klammern werden automatisch eingefügt!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten