Frage von iclasher, 37

minecraft server lädt plugin nicht?

Hallo, ich habe mir bei nitrado einen minecraft server gehostet und bukkit-1.8 installiert und wollte einige plugins wie essentials, LobbySystem und GommeNick installieren! Ich hatte vorher einen selbst gehosteten server bei dem alles einwandfrei lief... jetzt jedoch lädt das Plugin GommeNick nicht... in der Konsole steht:

[14:32:07 ERROR]: Could not load 'plugins/GommeNick_-_Version_2.0.jar' in folder 'plugins'org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: Nick/Nick : Unsupported major.minor version 52.0at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at java.lang.Thread.run(Unknown Source) [?:1.7.0_71]Caused by: java.lang.UnsupportedClassVersionError: Nick/Nick : Unsupported major.minor version 52.0at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_71]at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_71]at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_71]at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_71]at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]at java.lang.Class.forName0(Native Method) ~[?:1.7.0_71]at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_71]at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]... 6 more

Hoffentlich könnt ihr mir helfen:(

Mfg iclasher

Antwort
von Atomtoasty, 20

Deine Server datein (craftbukkit.jar) stimmt nicht mit der überein, die das Plugin braucht! Nutze doch die gleiche, wie die die du früher hattest

LG Atomsi

Antwort
von Moritz77Z, 9

Du benötigst folgende Spigot Startdatei:

http://tcpr.ca/files/spigot/spigot-1.8-R0.1-SNAPSHOT-latest.jar

Wenn du Craftbukkit benutzt:

http://tcpr.ca/files/craftbukkit/craftbukkit-1.8-R0.1-SNAPSHOT-latest.jar

Kp ob das Plugin 1.9/1.10 benutzt.

Bei Fragen schreib nen Kommentar.

Bix

Antwort
von iclasher, 20

[14:32:07 ERROR]: Could not load 'plugins/GommeNick_-_Version_2.0.jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: Nick/Nick : Unsupported major.minor version 52.0
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at org.bukkit.craftbukkit.v1_8_R1.CraftServer.loadPlugins(CraftServer.java:291) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at net.minecraft.server.v1_8_R1.DedicatedServer.init(DedicatedServer.java:152) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:505) [craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at java.lang.Thread.run(Unknown Source) [?:1.7.0_71]
Caused by: java.lang.UnsupportedClassVersionError: Nick/Nick : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_71]
at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_71]
at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_71]
at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]
at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_71]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_71]
at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_71]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]
at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_71]
at java.lang.Class.forName0(Native Method) ~[?:1.7.0_71]
at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_71]
at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[craftbukkit.jar:git-Spigot-8a983f9-e81edfc]
... 6 more

hier der richtige text!

sorry

Keine passende Antwort gefunden?

Fragen Sie die Community