Frage von Bf4lover, 42

Minecraft Plugin compile fehler - wie beheben?

Hallo,

ich habe heute angefangen mit dem Buch "Let´s Play Minecraft Plugins programmieren mit Java" angefangen.

Direkt beim ersten versuch, das aus dem Buch abgeschriebene Plugin zu compilen, wird mir eine Fehlermeldung ausgegeben (Siehe Bild 1). Das gesamte Script ist in Bild 2 zusehen.

Ich verwende als Server den Canary mod und als schreibprogramm JEdit. Ebenfalls habe ich das Pugin aus dem Buch, was auf der Website zur Verfügung steht gedownloaded und probiert - leider ohne Erfolg.

Ich hoffe hier kann mir jemand helfen.

Mit freundlichen Grüßen Bf4lover

Antwort
von JuicyLuisian, 41

Ich vermute das er die Bibliotheken die Canary Mod selbst nutzt nicht finden konnte. Da spielt eine menge Hintergrundwissen mit rein, wie ein Linker funktioniert, etc..

Die einfachste möglichkeit ist aber, meiner Meinung nach, mit einer Entwicklungsumgebung wie Eclipse zu arbeiten. So wie ich das sehe ist JEdit ja nur eine Editor, so wie Notepad++.

Wenn du Eclipse nutzt, kannst du einfach die alle Bibliotheken, die auf Canary basieren mit einbinden. Noch dazu hast du den Vorteil dein Code einfach runter zuschreiben und Eclipse sagt dir im nachhinein welche Bibliotheken du einbinden musst. Außerdem macht dich Eclipse schon wärend der Entwicklung auf Fehler aufmerksam, so das du es nicht extra Kompilieren musst.

Antwort
von Ping8502, 18

Ich habe genau das selbe Problem. Haben die Bibliotheken vielleicht einen neuen Namen bekommen??

@JuicyLuisian

In dem Buch wird beschreiben, dass hier nur einfache .java- Dateien benötigt werden, und Eclipse zu umfangreich für das Buch wäre. Für die paar Zeilen Text reicht sowas ja auch.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten