Minecraft Java Plugin funktioniert auf der 1.8 aber nicht auf der 1.7?

... komplette Frage anzeigen

3 Antworten

Kannst du den Code hier posten? Ohne den lässt sich vom Weiten nicht viel machen. (Am besten als pastebin-Link)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von MultiGamerLP
06.06.2016, 15:22

mainclass:
http://pastebin.com/aCnv3ver
plugin.yml:

name: SurvivalGames
version: 1.7.9

main: de.name.survivalgames.SurvivalGames

mehr hab ich noch nicht geschrieben.. das problem ist ja: auf der 1.8 funktionierts ja. nur auf der 1.7 findet er die mainclass nicht

0

Schonmal eine andere 1.7 Version versucht? 

Antwort bewerten Vielen Dank für Deine Bewertung

Wie sieht der ganze Stacktrace der Exception aus? (Am besten hochladen)

Aber Glückwunsch, ich sehe selten einen MC Dev der auch nur ansatzweise weiß wie Package- und Klassennamen auszusehen haben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von androhecker
06.06.2016, 20:52

Anscheinend ist das JRE welches du zum Ausführen benutzt eine niedrigere Version als dein JDK.

0
Kommentar von androhecker
07.06.2016, 17:31

Nitrado hat auch ein JRE, welches lässt sich mit etwas Java Code auch herausfinden. Einfach mal ein älteres JDK nehmen.

0
Kommentar von androhecker
10.06.2016, 18:59

Eigentlich die neueste Version (8 Update 92), aber du musst eben überprüfen welche Version Nitrado nutzt. Diese bekommst du mit Crash Reports, oder auch in Java mit System.getProperty("java.version")

0

Was möchtest Du wissen?