Frage von KRABBENFISCH, 33

Microsoft Excel: Lernspiel in Form eines Kreuzworträtsels mit der WENN-Funktion?

krabben, hoffe mir kann jemand weiterhelfen!

Wie erstelle ich ein Lerntest in Form eines Kreuzworträtsels bei Excel? Natürlich mit der Wenn-Funktion. Gibt ganz klassiche Aufgaben die man mithilfe der wenn funktion lösen kann.

Allerdings will ich das in Form eines Kreuzworträtsels verpacken.

Expertenantwort
von Ninombre, Community-Experte für Excel, 20

Die Frage verstehe ich nicht - was hast Du vor? Kreuzworträtsel muss Du halt optisch gestalten, jede Zelle entspricht dann einem Kästchen des klassischen Kreuzworträtsels.

Soll die Wenn-Formel dann für die Lösungsüberprüfung genommen werden? Das geht schnell und einfach aber auch in dem Du die Lösungsworte in eine Kopie des Kreuzworträtsel einträgst und erst einblendest, wenn das Rätsel gelöst wurde. 

Wo sollte denn sonst die Anzeige erfolgen, ob ein eingesetztes Wort richtig oder falsch ist? In einer separaten Zelle?

Das wäre mal ein Beispiel, wenn die Buchstaben von A1 bis A5 stehen und das Lösungswort ALPHA hieße. Über das Anzahl2 wird richtig / falsch erst angezeigt, wenn auch alle 5 Zellen gefüllt sind:

=WENN(ANZAHL2(A1:A5)=5;WENN(A1&A2&A3&A4&A5="ALPHA";"RICHTIG";"FALSCH");"")

Alternativ ginge es über die bedingte Formatierung. Bei dem Beispiel die Zellen A1 bis A5 markieren, bedingte Formatierung -> neue Regel -> Formel zur Ermittlung der bed. Formatierung verwenden

=A$1&A$2&A$3&A$4&A$5="ALPHA" und bspw. Hintergrundfarbe auf Grün setzen. Dann werden die Felder grün, wenn das richtige Wort drin steht.

Du musst dann pro gesuchtem Wort aber eine eigene bed. Formatierung anlegen.



Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten