Frage von Pessi2802, 45

Mehrere Werte mit Bedingung aus einer Tabellenspalte extrahierbar?

Hallo zusammen,

ich habe im Moment ein kleines Problem mit Excel.

Ich habe eine Tabelle mit einigen Angaben. Genannt sein hier einfach mal eine Summenspalte, die Geldbeträge addiert, bis 5% des Gesamtbetrages erreicht/überschritten wurden. Hinzu kommt eine Spalte, die eine jeweilige Kalenderwoche angibt.

Ich habe innerhalb der Summenspalte noch die Funktion eingebaut, dass, wenn die 5% erreicht/überschritten wurden, noch alle weiteren Geldbeträge in der selben Kalenderwoche dazu addiert werden.

Siehe hier das Bild, die grün formatierten Beträge sind die jeweils größte Summe ihrer KW.

Jetzt habe ich natürlich nicht nur diese 2 Werte, sondern einige mehr. Und eben diese hätte ich jetzt gerne in einer zweiten Tabelle aufgelistet, am besten mit der jeweiligen KW dazu geschrieben. Die Frage ist jetzt, wie ich das am besten anstelle, ohne es per Hand abzuschreiben. Ist das überhaupt möglich?

MfG

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 34

Am besten wäre es, wenn du mit gleicher Logik in einer zusätzlichen Spalte ein x schreibst, wenn die größte Summe der KW erreicht wurde.

Dann könntest du mit einem Filter dir alle Zeilen anzeigen lassen, die in dieser Spalte ein x stehen haben und nach Filterung irgendwo hin kopieren.

Kommentar von Pessi2802 ,

Das ist wirklich ein guter Ansatz..

Hatte aber fast auf etwas ähnliches gehofft, wie ich meine 'grün-Formatierung' hin bekommen habe..

da habe ich schlicht ein (in meinem Fall) =$M1>$M2 genommen..

weiß aber eben nicht ob oder wie ich das so 1:1 in eine externe tabelle übertragen kann..

wenn nicht, nehme ich wohl einfach die 'x'-Variante :D

Kommentar von Suboptimierer ,

Du kannst auch direkt nach Farbe filtern.

Kommentar von Suboptimierer ,

Um den letzten Wert einer KW zu finden, würde ein einfacher SVERWEIS reichen:

=SVERWEIS("Jahr,KW 2016,"&ZEILE(A46);L2:M100;2)
Expertenantwort
von Ninombre, Community-Experte für Excel, 29

Ermittelt werden soll also das Maximum pro KW?
=SUMMENPRODUKT((A:A="KW1")*MAX(B:B))/ZÄHLENWENN(A:A;"KW1")

Wobei im Bild nicht ersichtlich ist, ob die Spalten A und B sind.

Wenn Du in dieser zweiten Tabelle die Bezeichnungen so verwendest, wie in der Suchtabelle kannst Du statt der festen Werte ("KW1") auch auf die Zelle verweisen =Summenprodukt((A:A=B2....

Dann kannst Du die Formel einfach kopieren

Kommentar von Suboptimierer ,

Die Schwierigkeit besteht darin, dass KW 47 kein grünes Element hat (vermutlich, weil die 5% nicht erreicht wurden).

Kommentar von Ninombre ,

das stimmt - müsste der Fragesteller aufklären. Summenprodukt und eine zweite Spalte mit X würde sich auch ergänzen lassen

Kommentar von Pessi2802 ,

Suboptimierer hat es schon gut erkannt. Das Problem ist, dass nicht in jeder KW die 5% erreicht werden.. anhand der KW sollte/kann man da also recht wenig machen..

Kommentar von Suboptimierer ,

Es ist einfach nur eine zusätzliche Bedingung, die in das SUMMENPRODUKT gehört. Diese verkettest du mit * (das entspricht einem UND).

Die genaue Bedingung kennen wir nicht. 5% von was. Das ist alles aus dem Bild nicht ersichtlich. Du hast aber die Bedingung bereits vorliegen, nämlich dort, wo du den Gruppenwechsel machst. Diese musst du nur noch in die Formel integrieren.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten