Frage von Marceloblau01, 43

Mehrere =WENN(UND( miteinander verbinden, wer kann mir bitte dabei helfen?

Hallo liebe Experten,
Ich möchte mehrere Wenn(Und in einer Formel verbinden ich komme aber leider mit den Klammern und dem was zwischen den Wenn(Und stehen muss nicht klar. Vielleicht könnte mir jemand eine Formel schreiben mit 2-3 Wenn(Und( als Beispiel für das 1. wäre =WENN(UND(A1=B1; UND C1=0; DANN 1; SONST 0)) jetzt müsste das 2. wieder beginnen mit A1=D1 und E1=0 usw
Vielen Dank im voraus für eure Hilfe

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 26

Wie wäre es damit:

=WENN(UND(A1=B1;C1=0);1;WENN(UND(A1=D1;E1=0);2;WENN(UND(A1=F1;G1=0);3;0)))

Trifft das in etwa Deine Vorstellung?

Kommentar von Oubyi ,

Ich sehe gerade in Deinem Kommentar zu  Camilletekin, dass Du immer nur 1 als Ergebnis habe willst. Dann kannst Du Dir die WENN-Verschachtelung sparen:

=ODER(UND(A1=B1;C1=0);UND(A1=D1;E1=0);UND(A1=F1;G1=0))*1

Kommentar von Oubyi ,

Danke fürs

Antwort
von Camilletekin, 28

=WENN(A1>A3;A4;=WENN(A2>A5;A6))

Kommentar von Camilletekin ,

Also hab jetzt eigene zellbezüge benutzt

Kommentar von Marceloblau01 ,

diese Formel funktioniert gut wenn ich ein wenn und habe =WENN(UND(A1=B1;C1=0;1;0)) was ist wenn ich aber noch =WENN(UND(A1=D1;E1=0;1;0)) und dann noch =WENN(UND(A1=F1;G=0;1;0)) habe?
Ich könnte natürlich jedes in eine eigene Zelle machen und dann alle Zellen nach 1 und 0 abfragen aber geht das nicht auch mit einer Formel?

Keine passende Antwort gefunden?

Fragen Sie die Community