Frage von Bockwurstus, 54

Mehrere Tabellen bei excel zusammenlegen?

Moin,

Unzwar suche ich nach einer Möglichkeit mehrere Tabellenblätter sinnvoll auf einem Blatt zusammenzufassen. Ich habe dabei die Umsätze verscheidener Kunden aus verschiedenen Jahren und soll nun eine Tabelle mit einem Verlauf der Jahre machen.

Also ich habe in einer Datei die Jahre 2000-2015 und auf jedem Tabellenblatt ist ein Jahr tabellarsich dargestellt, aber nur mit Kunde + Kundennr + und den Umsatz. Jetzt soll auf einem Tabellenblatt ein Verlauf über die Jahre gemacht werden. Also in einer Spalte dann die Kunden, in der nächsten Spalte das Jahr 2000, dann 2001, etc. Und in einer Zeile jeweils ein Kunde.

Jetzt suche ich nach einer Möglichkeit das über ein Funktion zu machen, da es sonst sehr mühselig ware, jeden Kunden einzeln einzutragen und nachzuschauen, ob er jetzt eine neue Zeile benötigt oder zu einem schon vorhandenem Kunden gehört.

Ich weiß nicht, ob ich das jetzt verständlich genug formuliert hab? Aber vielleicht hat jemand ja schon eine passende Idee :)

Expertenantwort
von Ninombre, Community-Experte für Excel, 54

Das geht auch mit einem SVERWEIS. Ich kenne leider den Aufbau Deiner Datei nicht. Wenn die Tabellenblätter alle gleich aufgebaut sind und idealerweise wie die Jahreszahl heißen, könnte man komplett darauf verzichten, die Formeln anzupassen. Ansonsten eben die auszuwertenden Bereiche und Tabellenblattnamen manuell reinfrickeln.

So habe ich die Jahrestabellen verstanden:

Spalte A | Spalte B | Spalte C
Kunde    | KDNR     | Umsatz

Annahme: Es ist für die weitere Bearbeitung nichts mehr zu summieren, auch keine doppelten Einträge je Kunde vorhanden.

Manuell musst Du Dir allerdings die Mühe machen, alle Kundennamen einmal untereinander zu kopieren in ein neues Datenblatt und über Ribbon Daten -> Duplikate entfernen eine komplette Liste aller Kunden, die auf irgendeinem Tabellenblatt auftauchen zu erzeugen. Die gehört dann in die Übersicht in Spalte A

Die neue Übersichtstabelle habe ich so verstanden:

Spalte A | Spalte B | Spalte C | Spalte D

Kunde    | KDNR    | 2000       | 2001 ....

die Formeln ab C sind dann (wenn die Tabellennamen nicht dem Jahr entsprechen)

=WENN(ISTFEHLER(SVERWEIS($A2;Tabelle1!$A:$C;3;FALSCH));"";SVERWEIS($A2;Tabelle1!$A:$C;3;FALSCH))

Die Formeln kannst Du für das Jahr 2000 einfach runterziehen. Wenn Du sie nach rechts kopierst, musst Du für jedes Jahr das "Tabelle1" entsprechend auf den tatsächlichen Namen des Tabellenblatts ändern.

Ich sagte eingangs, dass man sich den Schritt sparen kann, wenn die Tabellenblätter so heißen (oder umbenannt werden können), die die Spaltenüberschriften. Also entweder die Tabellenblätter so nennen wie die Überschrift oder eben andersrum: Überschrift so wählen wie den Tabellenblattnamen.

=WENN(ISTFEHLER(SVERWEIS($A2;INDIREKT(B$1&"!A:C");3;FALSCH));"";SVERWEIS($A2;INDIREKT(B$1&"!A:C");3;FALSCH))

Sofern die Tabellenblätter mit den Jahresangaben immer gleich sind bzgl. der Spalten, kannst Du die Formel einfach quer über die Übersichtstabelle ziehen.

Kommentar von Iamiam ,

zur schnelleren Umsetzung hier noch ein VBA-Makro zum auflisten aller Blattnamen:

Sub BlattnamenListen()

Dim i As Integer

For i = 1 To Worksheets.Count

ActiveCell.Value = Worksheets(i).Name

ActiveCell.Offset(0, 1).Activate

Next

End Sub

Zieh aber auch mal den Vorschlag von Sawascwolf in Betracht (Pivottabelle)

Antwort
von Sawascwoolf, 53

Das hört sich sehr nach einem Einsatzgebiet für eine PivotTabelle an.

Keine passende Antwort gefunden?

Fragen Sie die Community