Frage von Ghanasoccer, 14

Matrix einer Excel Formel möchte nicht mit Anführungszeichen bzw. variabel angezeigt werden.Was kann ich tun?

Schönen Abend euch allen.

Ich möchte nicht lange Stören und habe deswegen nur eine kurze Frage, welche von den xlProfis bestimmt schnell beantwortet wird.

Die Frage hat das gleiche Thema wie Frage von gestern.

http://www.gutefrage.net/frage/wie-durchsuche-ich-meine-excel-datei-nach-bestimm...

Ich habe eine Funktionierende Formel:

=WENNFEHLER(ADRESSE(VERGLEICH("*"&$C$2&"*"&$D$2&"*"&$E$2&"*"&$F$2&"*";WENN(A1="Männer";Datensatz!A2:A26000;WENN(A1="Frauen";Datensatz!B2:B26000));0)+1;1);"Gibt’s nich!")

Sie hat den Sinn dass sie mir eine Position von einer Bestimmten Datenzeile gibt.

Die große Schwester funktioniert nicht:

=WENNFEHLER(ADRESSE(VERGLEICH("*"&$C$2&"*"&$D$2&"*"&$E$2&"*"&$F$2&"*";WENN($A$1="Männer";
"Datensatz!A"&SUMME(RECHTS($B5;LÄNGE($B5)-3);1)&":A26000";WENN($A$1="Frauen";
"Datensatz!B"&SUMME(RECHTS($B5;LÄNGE($B5)-3);1)&":B26000"
));0)+1;1);"Gibt’s nich!")

Der einzige Unterschied ist der MatrixPart:

|| ;"Datensatz!A"&SUMME(RECHTS($B5;LÄNGE($B5)-3);1)&":A26000"; ||

Kann man die Matrix auch anders angeben?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von DeeDee07, Community-Experte für Excel, 14

Ohne jetzt die Formel ganz genau nachzuvollziehen fällt mir auf, dass sie teilweise wie eine INDIREKT-Funktion aussieht, nämlich hier

"Datensatz!A"&SUMME(RECHTS($B5;LÄNGE($B5)-3)

Allerdings sehe ich nirgends eine Indirekt-Funktion.

Kommentar von Ghanasoccer ,

Danke dir endlich hab ich ne HAMMER Suchzeile in Excel xD


Ich kannte die Formel, aber leider ist der Mensch vergesslich.

Antwort
von PWolff, 11

Die Funktion, die du suchst, nennt sich "INDIREKT".

Wenn du auf eine ganze Spalte verweisen willst, kannst du das in Excel auch mit "A:A" bzw. "$A:$A" tun. (Entsprechend mit "1:1" bzw. "$1:$1" auf eine Zeile.) Mit OpenOffice/LibreOffice leider (noch?) nicht.

(Ich verwende diese Umwandlungsfunktionen zwischen Text und Zellbezügen nur sehr ungern - nicht, weil sie nicht funktionieren, sondern weil ich mir als Programmierer angewöhnt habe, schon im ersten Entwurf a) auf langsame Funktionen nach Möglichkeit zu verzichten und b) möglichst die Art von Funktion und Datenstruktur zu nehmen, die am nächsten beim Problem liegt. Beim Verschieben von Zellbezügen / Indizes sind das ganzzahlige Werte und keine Zeichenketten.)

Kommentar von DeeDee07 ,

In neuen Versionen (ich glaube ab 5) von LibreOffice funktioniert jetzt auch sowas wie A:A. In OpenOffice wohl noch nicht.

Kommentar von PWolff ,

Stimmt - danke für den Hinweis.

OpenOffice scheint inzwischen kurz davor zu stehen, aufgegeben zu werden. Neulich habe ich irgendwo gelesen, dass die Entwickler einer nach dem anderen abwandern.

Kommentar von Iamiam ,

"Potentialschritt/Volumenzugabe=Zellendifferenz Potential..."

NOCH muss man aufpassen, es funktioniert noch nicht in allen Funktionen!

Keine passende Antwort gefunden?

Fragen Sie die Community