Frage von mottwin, 57

Linux Mint Grafiktreiberproblem in Kombination mit Minecraft. Wie kann man das lösen?

Hey, ich nutze Linux Mint 17.2. Ich nutze im Moment den xserver-xorg-video-nouveau Treiber. Ich habe versucht Minecraft zu spielen, was in soweit geklappt hat. Aber ich habe festgestellt das ich die integrierte Intelgrafikkarte nutze und dementsprechend sehr schlechte Bildraten habe. Wenn ich jetzt versuche den Nvidiatreiber zu nutzen startet Minecraft nicht mehr und ich
habe keine Idee wie ich das beheben kann.

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Linuxhase, 52

Hallo

Ich nutze im Moment den xserver-xorg-video-nouveau Treiber. .... Aber ich habe festgestellt das ich die integrierte Intelgrafikkarte nutze

Das bedeutet Du hast eine Hybridgrafik, ergo solltest Du Dich mal über Bumblebee informieren:

https://wiki.ubuntuusers.de/Hybrid-Grafikkarten/Bumblebee

Zeig doch bitte zur Bestätigung was hierbei ausgegeben wird:

lspci -nnk | grep -iA2 vga

Linuxhase

Kommentar von mottwin ,

ok hab mal den Befehl im Terminal ausgeführt und das is dabei rausgekommen: 

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)Subsystem: ASUSTeK Computer Inc. Device [1043:122d]Kernel driver in use: i915

Kommentar von Linuxhase ,

@mottwin

ok hab mal den Befehl im Terminal ausgeführt und das is dabei rausgekommen: 

in Code-TAGs häte es besser ausgesehen:

00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller[8086:0416] (rev 06)
Subsystem: ASUSTeK Computer Inc. Device [1043:122d]
Kernel driver in use: i915

Damit wäre die Textformatierung beibehalten worden.

Da ich mit dieser Hardware noch keine Erfahrungen gemacht habe wundert es mich das, trotzt Deiner Hybridgrafik, nur ein Chipsatz ausgegeben wird......

ok habe bumblebee installiert und nach längerem friemeln funktionierts auch, danke

.....aber wenn es am Ende doch funktioniert freue ich mich für Dich und wünsche noch viel Freude damit. :-)

Davon würde mich nun die Ausgabe des gleichen Kommandos nochmal interessieren:

lspci -nnk | grep -iA2 vga
dpkg-query -l *bumblebee*

Linuxhase

Kommentar von mottwin ,

ok hier die andere Ausgabe, in Code-TAGs (wusste nicht wie das geht, sry)


mottwin@mottwin-X750JB ~ $ lspci -nnk | grep -iA2 vga00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086:0416] (rev 06)Subsystem: ASUSTeK Computer Inc. Device [1043:122d]Kernel driver in use: i915mottwin@mottwin-X750JB ~ $ dpkg-query -l *bumblebee*lspci -nnk | grep -iA2 vgadpkg-query: Kein Paket gefunden, das auf *bumblebee*lspci passtdpkg-query: Kein Paket gefunden, das auf -nnk passtmottwin@mottwin-X750JB ~ $ dpkg-query -l *bumblebee*Gewünscht=Unbekannt/Installieren/R=Entfernen/P=Vollständig Löschen/Halten| Status=Nicht/Installiert/Config/U=Entpackt/halb konFiguriert/ Halb installiert/Trigger erWartet/Trigger anhängig|/ Fehler?=(kein)/R=Neuinstallation notwendig (Status, Fehler: GROSS=schlecht)||/ Name Version Architektur Beschreibung+++-===================-==============-==============-===========================================ii bumblebee 3.2.1-5 amd64 NVIDIA Optimus support for Linuxii bumblebee-nvidia 3.2.1-5 amd64 NVIDIA Optimus support using the proprietar

ich sehe leider nicht durch was davon jetzt relevant ist

Kommentar von Linuxhase ,

@mottwin

ok hier die andere Ausgabe, in Code-TAGs (wusste nicht wie das geht, sry)

Schon besser aber nicht wie in Deiner Ausgabe des Terminal:

mottwin@mottwin-X750JB ~ $ lspci -nnk | grep -iA2 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller [8086::0416] (rev 06)
Subsystem: ASUSTeK Computer Inc. Device [1043:122d]
Kernel driver in use: i915

und:

mottwin@mottwin-X750JB ~ $ dpkg-query -l *bumblebee*lspci -nnk | grep -iA2 vga
dpkg-query: Kein Paket gefunden, das auf *bumblebee*lspci passt
dpkg-query: Kein Paket gefunden, das auf -nnk passt

Hier hast Du wohl selbst gemerkt das Du etwas falsch eingegeben hast ;-)

mottwin@mottwin-X750JB ~ $ dpkg-query -l *bumblebee*
Name Version Architektur Beschreibung
===================-==============-==============-===========================================
ii bumblebee 3.2.1-5 amd64 NVIDIA Optimus support for Linux
ii bumblebee-nvidia 3.2.1-5 amd64 NVIDIA Optimus support using the proprietar

Interessant dabei finde ich das die Terminalausgabe von lspci bei Kernel driver in use den gerade aktuellen Treiber angibt und nicht etwa beide. Logischerweise braucht man für's Terminal keinen proprietären Treiber weil ja keine großen Grafikleistungen benötigt werden.

Linuxhase

Kommentar von mottwin ,

ok habe bumblebee installiert und nach längerem friemeln funktionierts auch, danke

Antwort
von bmke2012, 57

Nouveau ist der freie Standardtreiber für NVidia-Karten. Der unterstützt leider nicht alle Eigenschaften/Möglichkeiten der Grakas. Du solltest deshalb die von NVidia in den Repos von Mint bereitsgestellten Module installieren. Das geht als root am schnellsten mit:

apt-get install xserver-xorg-video-nvidia

Damit werden die xserver-Dateien für Nvidia und in die zugehörigen Kernelmodule installiert. Zusätzlich solltest Du noch

apt-get install nvidia-settings

ausführen, um das Konfigprogramm für die Nvidiamodule zu installieren

Kommentar von mottwin ,

ok hab das ganze mal versucht aber es scheitert schon am ersten Befehl:

Paketlisten werden gelesen... Fertig

Abhängigkeitsbaum wird aufgebaut. 

Statusinformationen werden eingelesen.... Fertig

E: Paket xserver-xorg-video-nvidia kann nicht gefunden werden.


Kommentar von bmke2012 ,

O.K. dann gibt es dieses Paket in Mint wohl nicht! Schade.

Probier es mal mit:

apt-get install nvidia-346 nvidia-settings

und starte den Rechner neu. 346 sollte die aktuelle Version in Mint sein.

Eventuell musst Du noch den Nouveau-Treiber "blacklisten" (muss ich unter Debian interessanterweise nicht) oder komplett deinstallieren mit: 

apt-get remove --purge xserver-xorg-video-nouveau
Kommentar von mottwin ,

also wenn ich das richtig verstehe installiert der erste Befehl die Treiberversion 346, diese hab ich bereits und in der Systemsteuerung von Linux ist der jetzt auch als Standardtreiber eingestellt. Ich habe derweil mal bumblebee installiert (da der obige Befehl ja nicht funktioniert hatte) und habe es auch geschafft Minecraft mit der Nvidiakarte zum laufen zu bringen. Muss ich jetzt trotzdem noch den Nouveau-Treiber "blacklisten"?

und danke für die Hilfe


Kommentar von bmke2012 ,

Nö. Musst Du nur wenn der Nouveau anstatt des Nvidia-Treibers geladen würde. Dieses Problem gab es in früheren Mint- und Ubuntu-Versionen. Scheint mittlerweile behoben zu sein, wie ich Deiner positiven Aussage entnehme.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten