Frage von Edithsche, 59

Kundenumsatztabelle clustern?

Hallo, ich habe eine Kundentabelle, die unterschiedliche Umsätze in Spalte B aufweist. Diese würde ich gerne in C Clustern wie in dem beigefügten Bild dargestellt. Ich habe bereits folgende Formel verwendet, die mir aber nur 2 Werte wiedergibt, nämlich "10k" und "500-1k":
=WENN(B2>=500;"500-1k";WENN(B2>1000;"1,2,5k";WENN(B2>2500;"2,5-5k";WENN(B2>5000;">5k";"10k")))) Die Werte zwischendrin sind ja auch größer als 500, also eigentlich verständlich, daß diese Formel nicht funktioniert. Dann habe ich es per Index und Vergleich probiert: =INDEX($P$1:$Q$5;VERGLEICH(B2;$B$2:$B$52;0);2) Hier kommt auch nichts verwendbares raus, da die Werte aus Spalte P ja die Werte sind, bei denen "größer als" dieser Wert gesucht werden soll.

Kann mir jemand vielleicht weiterhelfen? Im Voraus vielen Dank!

Expertenantwort
von Ninombre, Community-Experte für Excel, 47

Im Grunde musst Du die Reihenfolge der Bedingungen nur umdrehen. Excel prüft bis die erste Bedingung erfüllt ist. Daher landen bei Dir momentan alle Werte >500 in der ersten Kategorie, denn auch 5000 ist ja >500. Excel sucht dann nicht weiter, ob es noch eine andere passende Bedingung gibt.
Also einfach die Bedingungen in der Reihenfolge größter Wert -> kleinster Wert

Der "sonst"-Wert "10k" ist etwas fraglich: Wenn B2 = 50 ist, dann greift ja keine der Bedingungen. Soll das wirklich in die Kategorie "10k"?

Im Kehrschluss: Ein Wert von 20000 würde in der bisherigen Formel auch von >5000 erfasst. Du brauchst also noch eine weitere Wenn-Bedingung >10000

Generell solltest Du prüfen, ob > oder >= richtig ist. Bei >5000 fällt 5000 noch in die vorherige Kategorie


Kommentar von Ninombre ,

Mit der Wenn-Formel kannst Du zu jedem Wert in der Liste die entsprechende Kategorie hinterlegen. Wenn Du direkt zählen willst, gibt es so:
=SUMMENPRODUKT((B2:B100>=500)*(B2:B100<1000))

bzw. bei der Kategorie 10k
=summenprodukt((B2:B100>10000)*1)

Kommentar von Ghanasoccer ,

Wenn wir wenn verwennden: ;)

=WENN(P1<1000;"500-1000";WENN(P1>=10000;"10k";WENN(P1<2500;"1-2,5k";WENN(P1<5000;"2,5-5k";WENN(10000>P1;">5k")))))

Kommentar von Edithsche ,

Super, viiiiielen Dank!!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten