Frage von OneHit08, 15

Kombinatorik wie viele nebeneinanderstehende Zahlen sind gleich?

Folgendes Problem:

Ich habe alle 5-stelligen zahlen von 10000 bis 99999, weil 00321 nur 3 stellig wäre.

Also 89999 zahlen, ist noch logisch

Aber wie viele Zahlen davon gibt es, bei den zwei nebeneinanderstehende Ziffern gleich sind?

Antwort
von UlrichNagel, 5

Das ist Variation der Klasse 2 bei n=5. Bin nicht sicher. müsste mit Wiederholung sein. Schau dir die Variationsformel an. Nein sind ja 10 Ziffern!

Expertenantwort
von Suboptimierer, Community-Experte für Mathematik, 3

Mindestens 2 oder genau 2?

Kommentar von OneHit08 ,

mindestens 2

Kommentar von Suboptimierer ,

Ich komme auf 34.389.

Habe von allen Zahlen von 10000 bis 99999 pro Zahl alle Vorkommnisse von 11 gesucht. Das Gleiche mit 22 .. 99 und die Wahrheitswerte, ob nicht gefunden wurde und-verknüpft. Dann habe ich alle Wahrheitswerte über alle Zahlen gezählt, bei denen mindestens ein Fund vorkam.

Kommentar von OneHit08 ,

Wie ist der Rechenweg dahinführend? Ich kann das nicht ganz nachvollziehen. Ich komme grad auf

9000+

9*100*10+

8*10*100+

7+1*100

=26700

Kommentar von Suboptimierer ,

Ich habe den Computer rechnen lassen.

Eigentlich schon beschrieben, aber nochmal in Kurzform:

  • Suche nach 11 .. 99 in 10.000 bis 99.999
  • Verknüpfe und die Wahrheitswerte, die angeben, ob die zweistelligen Zahlen gefunden wurden, mit und und negiere das Ergebnis.
  • Zähle alle Werte wahr des vorangegangenen Punkts.
Kommentar von Suboptimierer ,

Oder, bevor ich mich verbal verhaspel, die Formeln:

A2: =A1+1
B2: =ISTFEHLER(FINDEN("00";$A2))
C2: ...
K2: =ISTFEHLER(FINDEN("99";$A2))
L2: =NICHT(UND(B2:K2))

Das herunter ziehen, dann in N1:

=ZÄHLENWENN(L1:L99999;WAHR())

... Ah, hab meinen Fehler. Danke für den Hinweis! Das Zählenwenn darf nur bis 90000 gehen. xD

Kommentar von Suboptimierer ,

Dann komme ich auf 30.951

Kommentar von OneHit08 ,

Aber 99XXX würden ja auch alle wegfallen.

Kommentar von Suboptimierer ,

Ja klar fällt die Zahl 99XXX auch weg. Ich spreche nicht von der Zahl, sondern von den Zeilen. Diese brauchen nur bis 90.000 laufen. Am Anfang entstehen die Lücken durch die Zahlen bis 10.000.

Keine passende Antwort gefunden?

Fragen Sie die Community