Frage von island03, 22

Kennt jemand die Excel-Formel für Gruppenzugehörigkeit?

Hi, ich habe ein Formel-Problem in Excel und finde hierzu keine Lösung: Ich habe 4000 Personen, die sich in 300 unterschiedlich großen Gruppen befinden. Zusätzlich habe ich eine Spalte C, in der sich für jede Person ein Wert befindet. Also ungefähr so:

Spalte A: Personen-ID (Zahl) Spalte B: Gruppenzugehörigkeit (Zahl) Spalte C: individueller Zahlenwert für jede Person

Nun möchte ich in einer neuen Spalte D die Varianz des Wertes in C innerhalb der jeweiligen Gruppen berechnen. Wie kann ich diese Gruppenzuordnung in der Formel berücksichtigen? Das Ganze soll auch nur gelten, wenn in Spalte C nicht der Wert 999999 steht (aber das bekomme ich hin).

Ich freue mich sehr über Hilfe!

Expertenantwort
von Oubyi, Community-Experte für Excel, 17

Leider kenne ich mich in Statistik nicht aus und daher habe ich Varianz schon mal gehört, kann aber nicht viel damit anfangen. Ich denke aber, dass Du den Wert des Individuums mit dem Durchschnittswert der Gruppe vergleichen willst. Den Durchschnittswert der Gruppe bekommst Du für A1 mit:

=MITTELWERTWENN(B1:B4000;B1;C1:C4000)

Wenn dabei allerdings 999999 nicht berücksichtigt werden soll, geht das z.B. so:

=SUMMENPRODUKT(((B1:B4000=B1)*(C1:C4000<>999999)*(C1:C4000))/SUMMENPRODUKT((B1:B4000=B1)*(C1:C4000<>999999)))

Hilft Dir das weiter?
(Es kann sein, dass das auch einfacher geht, ich neige zum verkomplizieren, aber klappen sollte es.)

Kommentar von island03 ,

Hallo Oubyi, danke für deinen Tipp! Das trifft leider nicht ganz das, was ich brauche. Nur, um das hier zu vervollständigen: Aus einem anderen Forum habe ich gerade diese Lösung bekommen:

=WENN($B2<>$B3;VAR.P(WENN(($B3=$B$2:$B$11)*($C$2:$C$11<>999999);$C$2:$C$11));"-")

(Spalten A bis C wie oben beschrieben). Trotzdem lieben Dank für deinen Hinweis!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten