Frage von Marceloblau01, 40

Kann mir jemand helfen diese Matrix Formel umzuschreiben {=WENN(UND($BI12=2;$BO12=1);1;"")}?

Hallo liebe Excel Experten,

diese Matrix Formel {=WENN(UND($BI12=2;$BO12=1);1;"")} bezieht sich derzeit auf die Zelle BO12, kann mir jemand die Formel so umschreiben dass ich nicht nur BO12 sondern noch mehrere Zellen mit einbeziehen kann, also zB. noch die Zellen BP12,BQ12,BR12,BS12,BT12. Wichtig ist aber dass nicht in allen Zellen 1 stehen darf bevor am Ende nichts oder 1 steht. soll heißen wenn die Formel {=WENN(UND($BI12=2;$BO12:$BT12=1);1;"")} so aussieht dann ist das Ergebnis 1 erst dann wenn in allen Zellen eine 1 steht und das soll so nicht sein!

bitte helft mir!! MfG Uwe

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von DeeDee07, Community-Experte für Excel, 24

Wieso als Matrixformel? Du verwendest in der Formel keine Matrizen.

Die Bedingung soll also wahr sein, wenn BI12 = 2 und mindestens eine Zelle von BP12:BT112 <> 1 ist? (Bin mir aber nicht sicher, ob du dass so meinst - muss in diesem Bereich eine 1 vorkommen? Erläuter die Bedingungen genau)

Dann würde ich als Formel verwenden:

=WENN(UND($BI12=2;ZÄHLENWENN($BO12:$BT12;1)<6);1;"")

Falls in den genannten Zellen mindestens eine 1 vorkommen muss, dann als zusätzliche Bedingung im UND-Block

ZÄHLENWENN($BO12:$BT12;1)<0

Kommentar von Marceloblau01 ,

{=WENN(UND($BI12=2;ZÄHLENWENN($BO12:$BT12;1));1;"")} so funktioniert die Formel, danke für deine Hilfe !!!! <6 hab ich weggelassen!!!! super ich danke dir nochmals!

MfG Uwe

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 25

Den Satz "Wichtig ist aber dass nicht in allen Zellen 1 stehen darf bevor am Ende nichts oder 1 steht." verstehe ich nicht richtig.

Du willst überprüfen, ob der Bereich, über den du die Matrixformel ziehst, mit 1en gefüllt ist, während die Bedingung diese Zellen mit einschließt? Das wäre ein zirkulärer Bezug.

Du könntest es versuchen, die Iteration zu aktivieren:

Start → Optionen → Formeln → Iterative Berechnung aktivieren

Kommentar von Marceloblau01 ,

also die Formel bezieht sich derzeit auf BO12 >>{=WENN(UND($BI12=2;$BO12=1);1;"")} die Zelle in der die Formel steht bleibt leer wenn in BO12 eine 0 steht. Wenn da eine 1 steht und in BI12 eine 2 dann schreibt er in die Zelle eine 1.  wenn in BI12 eine 3 steht bleibt die Zelle wiederum leer. Jetzt habe ich aber statt BO12 noch andere Zellen zum überprüfen deshalb möchte ich diese anderen Zellen mit in diese Formel einbeziehen, aber möglichst so, dass Excel nicht erst rechnet wenn in allen Zellen BO12:BT12  eine 1 steht sondern wenn in einer von den 6 Zellen BO12:BT12 eine 1 steht. es spielt dabei keine Rolle ob in 2 oder 3 Zellen von BO12:BT12  eine 1 steht.

Die Aufgabe der Formel soll erhalten werden nur soll der Zellbezug auf BP12 bis BT12 erweitert werden

Kommentar von Suboptimierer ,

Bau doch ein ODER ein:

=WENN(UND($BI12=2;ODER($BO12:$BT12=1));1;"")
Kommentar von DeeDee07 ,

DH!

Für diese Version ist dann wiederum die Matrixformel notwendig.

Kommentar von Iamiam ,

oder ganz anderer Ansatz, ohne Matrixformeleingabe:

=($BI12=2)*(SUMMENPRODUKT(($BO12:BT12=1)*1)>=1)

(weil Summenprodukt eine verkappte Matrixformel ist)

WENN, UND, ODER, ZÄHLENWENN etc. gehen alle irgendwie auf logische Zellvergleiche zurück (letztlich auch höhere Funktionen), nur muss man den Text WAHR, FALSCH durch mathematische Operationen (hier *1) zu einer logischen 1 oder 0 umwandeln.

Auch >=1 liefert {WAHR;FALSCH, etc.}, aber die Multiplikation mit der ersten Klammer erledigt diese Umwandlung.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten