Frage von Hammerdrauf, 86

Kann mir bitte jemand eine passende Excel Formel für mein Problem geben?

Hallo!

Für eine Liste in der alle Dienste verknüpft sind möchte ich jede zweite (gräulich markierte) Zeile zählen. Dabei soll bei jeder zweiten Zeile gezählt werden wie oft "T" und "N" vorkommt (2 getrennte Formeln) damit die Anzahl in den beiden obersten Feldern (siehe Foto) angezeigt wird.

Ich hoffe mir kann jemand helfen. Danke ;)

 

 

EDIT:

Leider habe ich noch was vergessen: ES gibt insgesamt über 600 Zeilen und in den Zeilen die nicht gräulich markiert sind befindet sich öfters ein "T" oder "N" welches NICHT gezählt werden soll ;)

Expertenantwort
von Iamiam, Community-Experte für Excel, 18

am einfachsten und kürzesten (für jede Spalte extra in den obersten Zellen platziert) ist wohl:

=Summenprodukt((A4:A999="N")*Rest(Zeile(A4:A999);2)) für alle N in den ungeraden Zeilen und alternativ

=Summenprodukt((A4:A999="N")*Rest(Zeile(A4:A999)+1;2)) für alle N in den geraden Zeilennummern.

Gleiches für "T" oder jeden anderen -auch längeren- Eintrag, sofern nichts anderes zusätzlich in der gleichen Zelle steht. (auch dann ginge es, aber etwas komplizierter). Wichtig ist, dass es jede 2. Zeile ist, so dass Rest(...;2) als Faktor 0 oder 1 ergibt. Die graue Farbe auszuwerten, wäre um Größenordnungen komplizierter!

Ein aktiviertes Autofilter sollte die Formel nicht beeinflussen, sondern die nicht sichtbaren mitauswerten (probier das aber vorsichtshalber aus).

Antwort
von LeroyJenkins87, 51

versuch es mal mit der Funktion ZÄHLENWENN oder ZÄHLENWENNS.

Da kannst du ein Suchbereich definieren und ein Kriterium angeben, welches gezählt werden soll.

Kommentar von Hammerdrauf ,

Leider habe ich noch was vergessen: ES gibt insgesamt über 600 Zeilen und in den Zeilen die nicht gräulich markiert sind befindet sich öfters ein "T" oder "N" welches NICHT gezählt werden soll ;)

Kommentar von LeroyJenkins87 ,

Das ist schon was ganz Anderes. Da habe ich spontan leider auch keine Idee, wie man das lösen könnte. Aber falls du eine Lösung findest würde ich mich freuen, wenn du mir diese sagen könntest.

Viel Erfolg.

Antwort
von Funfroc, 35

Hallo,

in Ermangelung konkreter Bereiche kann ich dir nur ein Beispiel liefern, wie es möglich wäre.

{=SUMME((A1:Z10="T")*(REST(ZEILE(A1:A10);2)=1)*1)}

Zählt das Vorkommen von "T" in den Zeilen 1, 3, 5 usw.

Achtung Matrixformel. Eingabe ohne {}, Formel bestätigen mit STRG + Shift + Enter.

LG, Chris

Kommentar von Iamiam ,

DH!

die gleiche Idee. Ich hab nur sehr lange pausiert und dann erst mal ausprobiert, ob Summenprodukt anstatt Matrixformel geht und siehe da: es tut!

Antwort
von Hammerdrauf, 27

Hier ein Bild mit Zeilen und Spalten :)

Kommentar von Iamiam ,

nach diesem Bild geht meine Formel natürlich mit C4;C999="N" los

Expertenantwort
von Ninombre, Community-Experte für Excel, 34

Ein Bild ohne Spalten und Zeilenangaben ist nicht so hilfreich für eine konkrete Formel....

=SUMMENPRODUKT((REST(ZEILE(A1:A10);2)=1)*(A1:N10="T"))

Das wären die T in den ungeraden Zeilen, für die geraden die fett markierte 1 auf 0 setzen.

Kommentar von Funfroc ,

Die Antwort hab ich zu spät gesehen... funktioniert genau wie mein rumgestümper, aber eleganter.

Kommentar von Iamiam ,

ich auch. Man sollte wirklich jedesmal erst wieder aktualisieren, insbesondere, wenn man zwischendurch mal was anderes macht!

Kommentar von Hammerdrauf ,

Entschuldige, ich habe ein Bild nun als Antwort eingegeben. Könntest du mir bitte eine angepasste Formel geben ? Habe es selbst probiert aber da hat er mir einen Fehler angezeigt. Werde es nochmal durchprobieren ;)

Kommentar von Ninombre ,

=SUMMENPRODUKT((REST(ZEILE(A5:A28);2)=1)*(C5:AG28="T"))
die Spalten stehen nicht drauf, wenn es nicht bis AG geht, dann noch ändern.

In welcher Spalte man die Zeilen durchzählt ist egal, da geht es nur darum gerade / ungerade zu trennen (das funktioniert mit Rest:
Zeile(A5) liefert als Ergebnis 5. 5/2 ergibt Rest=1 also wird diese Zeile betrachtet.

Kommentar von Iamiam ,

Himmiherrgottsakramentzefixalleluja! Weil ihr Euch jedesmal irgendwelche Angaben spart, haben wir immer die doppelte Schreibarbeit und oft noch mehr!

Antwort
von Jodel92, 53

=ZÄHLENWENN(Bereich;"N")

Entsprechend natürlich auch mit T

Kommentar von Hammerdrauf ,

Leider habe ich noch was vergessen: ES gibt insgesamt über 600 Zeilen und in den Zeilen die nicht gräulich markiert sind befindet sich öfters ein "T" oder "N" welches NICHT gezählt werden soll ;)

Kommentar von Jodel92 ,

Wieviele Spalten hat denn die Tabelle? Ich würde mir sonst evtl. mit einer Hilfsspalte je Spalte verhelfen, in denen du nur in jede zweite Zeile schreibst: =wenn(Spalte="n";"n";wenn(Spalte="t";"t";0)))
Dann kannst du in dieser Hilfsspalte die die Ns und Ts zählen.
Die Formeln kriegst du ja einfach in jede zweite Zeile, indem du eine Formel einträgst, die nächste Zeile mit markierst und dann herunterziehst..
Ich hoffe, du verstehst, was ich meine.

Kommentar von Jodel92 ,

Di Hilfsspalten kann man ja auch später ausblenden, sodass keiner das sieht.

Kommentar von Jodel92 ,

Geht übrigens auch einfacher, wenn du in der Hilfsspalte einfach nur "=Zelle der Hauptspalte" einträgst :)
Tja, wenn man erst einmal komplex denkt :)

Kommentar von Hammerdrauf ,

Danke - Die Tabelle hat über 30 Spalten und das Format sollte ungefähr gleich bleiben ;)

Antwort
von Jodel92, 35

Hier der Screenshot, wie ich das meine.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten