Kann man in Excel mit VBA eine Zelle wie folgt programmieren?

... komplette Frage anzeigen

2 Antworten

Dafür könntest Du die Datenüberprüfung nutzen.

Benutzerdefiniert > Formel
=ANZAHL(B1:F1)=5
bzw. entsprechend angepasst auf den Bereich, den Du prüfen willst.

Nur wenn die Bedingung erfüllt ist, lässt sich etwas in die Zelle eintragen.

Unter Fehlermeldung kannst Du auch was sprechendes hinterlegen bzw. die Art des Hinweises anpassen (d.h. ob man trotz des Fehlers etwas eintragen kan oder nicht)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
02.02.2016, 16:05

Wenn ich den Kommentar zur anderen Antwort richtig verstanden habe darf der Wert in A1 nicht größer sein als die Anzahl von Zahlen in einem bestimmten Bereich. Unter der Annahme, dass dieser Bereich B1:F5 wäre, ist die Formel für die Datenüberprüfung:

=ANZAHL(B1:F5)>=A1

0
Kommentar von Marceloblau01
02.02.2016, 20:13

Danke ich werde es morgen noch mal probieren

0

Hier eine nicht VBA Lösung:

Angenommen, du schreibst die Zahl in $A$1. Dann kannst Du dort als erstes eine Datenprüfung auf eine Ganze Zahl machen.

Für die Zahlenreihe machst Du dann eine bedingte Formatierung, welche sich immer auf $A$1 bezieht.

Formel: =WENN($A$1=B1;WAHR;FALSCH)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Marceloblau01
02.02.2016, 00:27

Vielleicht hab ich es schlecht erklärt, ich versuche es noch mal, nehmen wir an A1 ist die bestimmte Zelle, ich gebe nun eine 1 ein, für meinen Suchlauf sagen wir A2 bedeutet das nun ich möchte dort eine Zahl sagen wir aus dem Bereich D1:F10 , dieser Bereich ist immer unterschiedlich mit Zahlen gefüllt oder aber auch mal keine, aber da ich in meinem Fall den Bereich nicht im Blickfeld habe so wie im Beispiel möchte ich gewarnt oder daran gehindert werden wenn der Bereich keine Zahlen enthält und somit der Suchlauf ins leere laufen würde .

0

Was möchtest Du wissen?