Frage von Larusso8481, 35

Wie kann man Excel Termine in ein Tabellenblatt eintragen und dann in passende Monatsblätter einfügen bzw übertragen?

Hallo zusammen,

ich habe eine Ausgabentabelle in der jeder Monat ein Tabellenblatt ist. In jedem Monatsblatt ist in Spalte B das Datum des Monats fortlaufend nach unten. Nun möchte ich auf ein extra Tabellenblatt in Spalte A das Datum fortlaufend nach unten für das ganze Kalenderjahr eintragen und in Spalte B was an dem Tag ist (ist ein Abfallkalender der in der Ausgabenliste mit angezeigt werden soll). Die Informationen aus Spalte B soll dann passend in jedem Monatstabellenblatt in Spalte B wiedergegeben werden. Ich komme da mit dem Sverweis nicht wirklich weiter weil ich damit wenig bis gar nicht gearbeitet habe. Also quasi eine Datenbank auf einem extra tabellenblatt in dem ich einen Termin pro Tag des Kalenderjahres eintragen kann der mir dann auf dem jeweiligen Monatsbaltt neben der Datumsspalte angezeigt wird. Vielleicht hat jemand eine einfache Lösung. Ich nehme auch gerne VB Lösungen an. Vielen dank schon mal für eure Hilfe.

Expertenantwort
von Ninombre, Community-Experte für Excel, 20

ich würde es mit dem SVERWEIS angehen.

Du hast in den Monatstabellenblättern ja ein Datum stehen. Damit kannst Du in der Jahresübersicht die Vorgänge auslesen.

=WENNFEHLER(SVERWEIS(B5;Tabelle1!A:B;2;FALSCH);"")

B5 wäre hier das erste Datum auf dem Monatsblatt. Wichtig ist, dass es ein richtiges Datum ist.
Tabelle1 eben die Jahresübersicht

Kommentar von Larusso8481 ,

funktioniert super, wenn du mir noch sagen kannst wie ich die "0" aus den leeren Feldern bekomme habe ich alles was ich benötige.

Kommentar von Ninombre ,

Das mit der 0 wundert mich - Wann tritt das auf, also welche Felder sind in diesem Fall leer? Das Datum auf der Monatsübersicht oder gibt es zu diesem Datum keinen Eintrag in der Jahresübersicht?

Kommentar von Larusso8481 ,

in allen Felder wo es keinen Termin gibt steht "0" in den anderen Feldern steht der Termin passend.

Kommentar von Ninombre ,
=WENNFEHLER(TEXT(SVERWEIS(A21;Tabelle1!A:B;2;FALSCH);"#");"")
Kommentar von Iamiam ,

eine gute Idee, einen Fehler zu provozieren! Ich hab das bisher immer mit 1/1/Formel gemacht!

Wobei man die Null auch über ein bendef Format wegkriegen kann, da ich aber wissen will, ob überhaupt was in der Formel steht, mach ich die Nulldarstellung üblicherweise als magenta-° oder ähnliches.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten