Frage von Elenor12, 27

Kann man die Dropdownfunktion in Excel mit einer Wenn/Dann-Formel kombinieren, bzw. ist es möglich die Auswahl zu begrenzen bis eine Summe X erreicht ist?

Hallo zusammen,

ich habe eine Exceltabelle, die wie folgt aussieht:

Verfügbare Menge 400 500

Kunde Karte Kalender

Müller 1 2

Meyer 1 1

Schulz 2 4

Die verfügbare Menge ist eine vorgegebene Größe. Nun kann je Kunde die Menge via Dropdown ausgewählt werden (Ist nötig, dass eine bestimmte Menge nicht überschritten wird). Wie kann ich es allerdings regeln, dass die Auswahl der Menge nur bis zum Erreichen der verfügbaren Menge möglich ist? Bzw. Ist das überhaupt möglich?

Ich danke schon einmal ganz sehr im Voraus für eventuelle Hilfe.

Expertenantwort
von Ninombre, Community-Experte für Excel, 22

Wenn Du nicht die Liste für ein Dropdown zwingend brauchst, kannst Du bei Datengültigkeit auf benutzerdefiniert gehen und die beiden Bedingungen mit einer Formel abfragen:

=UND(B2<=10;SUMME(B$2:B$100)<=400)
In Spalte B stehen bei meinem Beispiel die Karten je Kunde. Über die Formel ist die Grenze von 10 pro Kunde und insgesamt 400 gesetzt. Es kommt aber die gleiche Fehlermeldung, es lässt sich da nicht unterscheiden, welche Grenze überschritten wurde. Bei Fehlermeldung kannst Du einen Text hinterlegen, der die beiden Grenzwerte erläutert.

Eine andere Möglichkeit wäre die gültige Menge dynamisch zu ermitteln, wenn die Menge unbedingt über ein Dropdown eingegeben werden soll:
Meine Beispielliste, die als Liste in der Datengültigkeitsprüfung hinterlegt wird, steht von F1-F10
=WENN(SUMME(B$2:B$100)<=400-ZEILE(A1);ZEILE(A1);"")
Das generiert die Werte 1-10, solange die Gesamtzahl unter 400 liegt, kommt die Gesamtzahl der 400 näher, reduziert sich die Auswahlmenge bzw. ist irgendwann komplett leer. Allerdings: Ich bekomme da keine Logik eingebaut, dass eine bereits getroffene Auswahl wieder verringert werden kann - das ist der Fall, wenn ein Kunde bspw. 10 Karten bereits hinterlegt hat und die Gesamtmenge aufgebraucht ist. In diesem Fall ist die Auswahlmöglichkeit nur "nichts", obwohl es ja sinnvoll wäre eine Zahl kleiner der bisherigen Auswahl zuzulassen. Das sprengt aber die Möglichkeiten der Datenprüfung an dieser Stelle.

Kommentar von Elenor12 ,

Vielen lieben Dank für die Hilfe. Da das doch alles sehr umfangreich ist, werde ich den Dropdown entfernen und mit Hinweisen arbeiten (in der Hoffnung meine Kollegen können auch gut lesen ;) )

Kommentar von Ninombre ,

hey, nicht so schnell aufgeben! Den Dropdown mit der Liste 1-10 oder wieviel maximal zulässig ist, kannst Du ja wie geplant einbauen. Damit ist zumindest abgefangen, dass jemand mit dicken Fingern eine völlig falsche Menge eintippt.

Die Prüfung auf die Gesamtzahl kannst Du in einer Zeile oberhalb der Überschriften einbauen. Da reicht einfach summe(B2:B100) oder ähnliches aus.

Den Hinweis entweder als Text:

=WENN(SUMME(B2:B100)>400;"ACHTUNG ZUVIELE KARTEN! "&SUMME(B2:B100);SUMME(B2:B100))

oder als bedingte Formatierung. Zelle markieren > neue Regel > Formel: =summe(B2:B100)>400 und das Formatierung Rot oder ähnliches nehmen.

Keine passende Antwort gefunden?

Fragen Sie die Community