Frage von JapaneseGeneral, 42

Kann man bei Excel jede dritte Auswählen?

Ich erstelle mir gerade eine Exceltabelle zur Tagesplanung und Auswertung. Dabei besteht ein Tag aus drei Zellen. Ich habe jetzt allerdings einige Formeln, die mit den Werten mehrerer Tage rechnen sollen. Natürlich könnte ich jeden Tag einzeln hinzufügen, allerdings ist das natürlich sehr aufwändig.

Daher die Frage gibt es eine Möglichkeit eine Formel so zu erstellen, dass nur der Wert jeder dritten Zelle genutzt wird?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 13

Es kommt auf die Formel an. Zum Beispiel kann man mittels Matrixformeln jede dritte Zelle summieren:

=SUMME(WENN(REST(ZEILE(A:A);3)=0;A:A;0))

Solche Formeln musst du mit Strg + Shift + Enter abschließen.

Kommentar von JapaneseGeneral ,

=SUMME(WENN(REST(ZEILE(B35:CH35);4)=0;B35:CH35;0)) 

so habe ich die Formel angepasst. Welchen Fehler habe ich gemacht? (es ist jede 4.) Die Formel hatte ich abgeschlossen. Das Ergebnis war "0".

Kommentar von Suboptimierer ,

Du summierst über die Spalten, also musst du anstelle ZEILE SPALTE schreiben.

Kommentar von Oubyi ,

DH!
Da ich es möglichst vermeide eine "echte" Matrixformel zu nutzen, hier eine Alternative mit eine einfachen Formel, also nur mit Enter eingeben:

=SUMMENPRODUKT((REST(SPALTE(B35:CH35)+2;4)=0)*(B35:CH35))

Das ist schon an Deine Spalten angepasst und die +2 sorgt dafür, dass die erste Spalte die Spalte B ist. Wenn das anders sein soll, einfach 0 oder 1 oder 3 eingeben.

Teste aber auf jeden Fall genau.

Antwort
von Y0DA1, 12

Deine Ausführungen kann man nicht so einfach nachvollziehen.

Du musst nicht jeden einzelnen Tag hinzufügen. Du kannst einfach immer einen Tag weiter in einer neuen Zeile oder Spalte mit +1  (=A1+1) weiter springen.

Daher die Frage gibt es eine Möglichkeit eine Formel so zu erstellen, dass nur der Wert jeder dritten Zelle genutzt wird?

Na einfach die dritte Zelle ansprechen =C2.........

Ich glaube du musst nochmal richtig erläutern, was du wissen willst ^_^

Kommentar von JapaneseGeneral ,

Beispeilsweise habe ich die folgende Formel:=SUMME(B36;F36;J36....) die Summenformel soll erweitert werden jeweils um vier (nicht drei das war wohl ein Fehler), also möchte ich die Reihe bei der Summenformel vom nicht einzeln eintippen müssen.

Kommentar von Y0DA1 ,

Als einfach Lösung, könntest du nicht einfach die Summe so bilden? =SUMME(B36:CZ369)

Wenn du in den 3 zwischen Zellen auch was sehen hast, fällt mir nur ein, jede 4 Zeile in eine separate Spalte ausgeben lassen (die du ja ausblenden oder in einer anderen Tabelle der Datei verbergenkannst. Dann machst du eine Summe dieser Spalte und hast ein Ergebnis.

So:

Zelle C36 "=WENN(REST(ZEILE(B36);4)=0;B36;0)"    =z.B. 10
Zelle C37 "=WENN(REST(ZEILE(B37);4)=0;B37;0)"    =z.B. 0
Zelle C38 "=WENN(REST(ZEILE(B38);4)=0;B38;0)"    =z.B. 0
Zelle C39 "=WENN(REST(ZEILE(B39);4)=0;B39;0)"    =z.B. 14

Zelle B1   "=SUMME(C36:C39)"                                     =z.B. 24


Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten