Frage von lisalocke07, 65

kann ich bei einer Verknüpfung von 2 Exceltabellen in den sverweis eine Bedingung einfügen?

Ich habe 2 Exceltabellen, die ich verknüpfen möchte. In der zweiten ist der Schlüssel in mehreren Sätzen vorhanden. Die Verknüpfung erfolgt über die Rechnungsnummer, in der zweiten Tabelle interessiert mich nur der Datensatz, bei dem in Feld C "Preis" steht. Beispiel Tabelle 1, (1 Satz) Feld A: Rechn. Nr. 35

Tabelle 2, (2 Sätze, beide Feld B Rechn. Nr. 35) Satz 1: Feld C : Preis, Feld D: 9,95€ Satz 2: Feld C: Porto, Feld D: 2,60€ Durch eine Verknüpfung mit Tabelle 2 möchte ich in Feld E der Tabelle 1 den Wert 9,95€ erhalten. Wie funktioniert das? Danke im Voraus für die Hilfe LG lisalocke07

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Oubyi, Community-Experte für Excel, 49

Angenommen in Tabelle1 steht in der Zelle A1:
Rechn. Nr. 35
und dasselbe steht in Tabelle2 mehrfach in Spalte B, wobei nur einmal in Spalte C dazu "Preis" steht und in D der Preis.
Dann in Tabelle1 in Zelle E1 diese Formel (und runterkopieren falls gewünscht):

=SUMMENPRODUKT((A1&"Preis"=Tabelle2!B1:B1000&Tabelle2!C1:C1000)*(Tabelle2!$D$1:$D$1000))

Teste mal genau.
Habe ich Dich richtig verstanden?
Klappt es?

Kommentar von Iamiam ,

DH! ich hab lange gerähzzelt, was nun wo steht und wie zu verknüpfen und bin immer noch zu keinem endgültigen Schluss gekommen, hat sich durch Deine AW jetzt auch erübrigt!

Kommentar von Oubyi ,

Danke fürs

Kommentar von lisalocke07 ,

Vielen Dank, es hat jetzt geklappt, nachdem ich erst die Formel, die perfekt war, falsch übernommen hatte.

Mir war nicht klar, dass sich die Möglichkeit zu kommentieren hinter den 3 Punkten versteckt ;-).

Jetzt noch eine Frage dazu: Wenn ich in das Preisfeld einen Text schreibe, wird der nicht angezeigt, nur Werte. Wie funktioniert das, wenn in dem als Preis deklarierten Feld ein Text steht?

Kommentar von Oubyi ,

Das würde so funktionieren, unter der Voraussetzung, dass die Kombination
B: Rechn. Nr. 35 und C: Preisin den Spalten nur EINMAL vorkommt:

=INDEX($D$1:$D$1000;SUMMENPRODUKT((A1&"Preis"=Tabelle2!B1:B1000&Tabelle2!C1:C1000)*(ZEILE(Tabelle2!$D$1:$D$1000))))

Achtung!Wenn das mehrfach vorkommen kann wird kein Fehler angezeigt, sondern eine falsche Ausgabe!
Dann sag Bescheid, dann muss ich mir noch mal was einfallen lassen.

Kommentar von Oubyi ,

P.S.:
Falls die Kombi mehrfach vorkommen kann, würde diese Formel (und runterkopieren) Dir alle Preise untereinander anzeigen:

{=INDEX($D$1:$D$10;KKLEINSTE(WENN($A$1&"Preis"=Tabelle2!$B$1:$B$10&Tabelle2!$C$1:$C$10;ZEILE(Tabelle2!$D$1:$D$10));ZEILE(A1)))}

**ACHTUNG!**
Das ist eine Matrixformel.
Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit:
STRG & SHIFT & ENTER (alle drei gleichzeitig).
DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Kommentar von lisalocke07 ,

Es kann in diesem Fall nur einmal vorkommen, aber vielen Dank auch für die Egänzung. Ich werde es mir notieren, falls ich es noch mal brauche.

Antwort
von lisalocke07, 41

hat leider nicht geklappt, wahrscheinlich habe ich mich falsch ausgedruckt, hier noch mal in Reinform:

Tabelle 1:  A-1: 35

Tabelle 2: B-1:35, C-1: Preis, D-1: 9,95

Tabelle 2: B-2: 35, C-2: Porto, D-2: 2,60

gewünschtes Ergebnis: Tabelle 1: E-1: 9,95

Versuch: E1=SUMMENPRODUKT((A&"Preis"=Tabelle2!B1:B1000&Tabelle2!C1:C1000)*(Tabelle2!$D$1:$D$1000))

Ergebnis:E-1: #NAME?  :-(

Kommentar von schmiddi1967 ,

Das heisst auch nicht A&"Preis"sondern A1&"Preis" dann geht das auch.

Du musst nächstes mal direkt bei den Antworten dein Kommentar abgeben, bei ganz neuen Antworten bekommt man nicht bescheid.

Habe deine Antwort auch nur zufällig gelesen.

Kommentar von lisalocke07 ,

Dass sich hinter den 3 Punkten das Kommentarfeld versteckt, habe ich leider gerade erst zufällig bemerkt, danke für den Hinweis

Expertenantwort
von Iamiam, Community-Experte für Excel, 40

pro Forma

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten