Frage von WasIstPvP, 21

Java Plugin funktioniert nicht kann mir jemand helfen?

Error occurred while enabling Tablist v0.1 (Is it up to date?) java.lang.NullPointerException at me.rang.rang.onEnable(rang.java:32) ~[?:?] at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:321) ~[spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:335) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:405) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugin(CraftServer.java:356) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.enablePlugins(CraftServer.java:316) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.reload(CraftServer.java:746) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.Bukkit.reload(Bukkit.java:534) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java:25) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [spigot.jar:git-Spigot-870264a-0a645a2] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.dispatchCommand(CraftServer.java:646) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.PlayerConnection.handleCommand(PlayerConnection.java:1139) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.PlayerConnection.a(PlayerConnection.java:974) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.PacketPlayInChat.a(PacketPlayInChat.java:45) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.PacketPlayInChat.a(PacketPlayInChat.java:1) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.PlayerConnectionUtils$1.run(SourceFile:13) [spigot.jar:git-Spigot-870264a-0a645a2] at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_101] at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_101] at net.minecraft.server.v1_8_R2.SystemUtils.a(SourceFile:60) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.MinecraftServer.A(MinecraftServer.java:712) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.DedicatedServer.A(DedicatedServer.java:368) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.MinecraftServer.z(MinecraftServer.java:651) [spigot.jar:git-Spigot-870264a-0a645a2] at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:554) [spigot.jar:git-Spigot-870264a-0a645a2] at java.lang.Thread.run(Thread.java:745) [?:1.8.0_101]

Antwort
von VitaminSurge, 16

vielleicht das Plugin aus dem Internet updaten? c:

Kommentar von WasIstPvP ,

Ich hab es selber geschrieben

Antwort
von androhecker, 15

In Zeile 321 von deiner Plugin Klasse greifst du auf ein Objekt zu, dessen Wert null ist. Mehr kann man daraus nicht lesen, den Fehler solltest du selbst finden.

PS: me.rang ist ein schlechter Paketname und rang auch ein furchtbarer Klassenname.

Antwort
von VitaminSurge, 17

könntest du in den Titel bitte "Bukkit" schreiben c: weil es nicht nur java is sondern Bukkit Java und Bukkit is ziemlich anders !

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten