Frage von sandra0606, 54

Inventur Excel?

hallo

also ich möchte für das Jahr 2015 die Stückpreise aus der Tabelle 2014 zu den jeweiligen Artikelnummern erfassen. wie kann ich es in eine Formel fassen , wenn ich will dass die Spalte Artnr. 2015 mit der aus 2014 verglichen wird und bei Übereinstimmung soll dann der dazugehörige Stückpreis (nur in 2014 erfasst ) übernommen werden.

Danke =)

Expertenantwort
von schmiddi1967, Community-Experte für Excel, 24

Also wenn beide Tabellen in einer Datei sind kannst du das ganz einfach mit dem Sverweis machen.

Also in Tabelle 2015 ab A2 sind deine Artikelnummern und du möchtest in B2 jetzt den Stückpreis aus Tabelle 2014 haben.

Ich gehe weiter davon aus das Tabelle 2014 wie folgt aufgebaut ist:

Ab A2 die Artikelnummern und in B2 der Stückpreis, dann sieht die Formel so aus:

=SVERWEIS(A2;Tabelle 2014!$A$2:$B$16;2;0)

Tabelle 2014 musst du so ändern wie deine Tabelle heisst und den Bereich A2-B16 musst du so anpassen wie groß deine Tabelle da ist.

Diese kannst du dann ganz einfach runterziehen.

Kommst du so damit klar?

Wenn nicht musst du mir schon sagen wie deine Tabellen aussehen und in welchem Bereich sich deine Daten befinden.

Kommentar von sandra0606 ,

Danke schon mal für die schnelle Antwort

habe die Artnr. 2015 ab C2 und in 2014 ab B2 die Preise ab L2.

hatte das =SVERWEIS(C3;'2014'!$B$2:$L$2;2;0) als Formel verwendet klappt aber leider nicht. 

ich habe hier fast 10.000 Artikel ....bei denen entweder wenn die Artnr. übereinstimmen der Stk Preis aus 2014 erscheinen soll oder wenn die Artnr. neu ist das Wort neu

Kommentar von schmiddi1967 ,

Ah ok, das ist ja wieder was anderes, dann nimm mal diese hier:

=WENNFEHLER(SVERWEIS(C2;'2014'!$B$2:$L$10000;11;0);"Neu")

Hier ist jetzt zur Verständnis der Bereich in Tabelle 2014 von B2-L10000 für deine Artikel drin. Eventuell musst du das 10000 noch erhöhen wenn deine Tabelle weiter runter geht.

Die 11 in der Formel gibt an aus welcher Spalte in deiner Tabelle 2014 (Hier L) der Wert ausgegeben werden soll. Eigentlich wäre Spalte L die Zahl 12, da deine Tabelle aber erst ab B begint wird der Wert 11 Spalten weiter rechts ausgegeben.

Wenn der Wert in Spalte L nicht steht kommt Neu.

Verständlich?

Kommentar von sandra0606 ,

ne , das funktioniert leider auch nicht. dann kommt bei jeder Artnr neu

vielleicht habe ich mich auch falsch ausgedrückt.

ich muss  jede in Artnr. die in 2015 geführte nr mit denen in 2014 vergleichen und dann den Preis in 2015 einfügen

sprich wenn Artnr. xy 2015=Artnr. xy 2014 Dann Preis2014 zur Artn Nr xy

Kommentar von sandra0606 ,

Nochmal zum Verständnis, der Wert muss doch in Spalte B stehen um dann den dazu passenden Preis als L zu wählen 

Kommentar von schmiddi1967 ,
Nochmal zum Verständnis, der Wert muss doch in Spalte B stehen um dann den dazu passenden Preis als L zu wählen 

Das soll jetzt heißen das du in 2015 die Artikelnummer in B2 eingibst die gesucht werden soll? Also wahrscheinlich in A2 die Bezeichnung?

Deine Tabelle 2014 ist dann mit Daten von Spalte A - L runter bis Zeile 10000 gefüllt, wo die Artikelnummer die gesucht werden soll ebenfalls in Spalte B steht und der Preis der nachher in 2015 in Spalte B auftauchen soll in Spalte L steht?

Wenn ja sollte das diese Formel sein:

=WENNFEHLER(SVERWEIS(B2;'2014'!$B$2:$L$10000;11;0);"Neu")

Wenn nicht kann ich dir nurnoch anbieten das du mir ein Screenshot deiner Tabellen an die Email Adresse in meinem Profil sendest, weil dann wohl irgendwas da nicht stimmt oder wir eventuell auch aneiander vorbei reden.

Kommentar von Funfroc ,

Vielleicht wäre auch eine Beschreibung von "Funktioniert nicht" sinnvoll... Welches Ergebnis bekommst du? Bekommst du #NV oder einfach einen falschen Preis? Wie lautet deine Formel nach den letzten Anpassungen?

Im ersten Kommentar hattest du als Suchargument C3, obwohl du lt. Beschreibung bei C2 anfangen wolltest... das kann natürlich schnell ein Fehler sein.

Kommentar von sandra0606 ,

Sorry war alles richtig die spalten waren nur unterschiedlich formatiert und deshalb hat's zuerst nicht geklappt. 

Vielen dank für deine Hilfe!!!

Kommentar von schmiddi1967 ,

Bitte gerne :))

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten