Frage von MrCreeper2011, 53

Invaild Plugin.yml?

Ich habe ein Plugin gemacht, aber hatte beim Testen einen Error!

Mehr Infos zum Error etc. hier: http://pastebin.com/LJB5tgzZ

Ich habe alles wie im Tutorial von Lonzbonz gemacht

Vieleicht weil das Tutorial alt war, und es in der 1.6 war?

Antwort
von EnderStarLP, 40

Du hast keine plugin.yml

Kommentar von MrCreeper2011 ,

Schau bei dem Link, ich habe sie :) Trotzdem Danke für die schnelle Antwort :) Vieleicht habe ich sie vergessen in die Jar zu packen, ich Exportiere das Plugin nochmal :)

Kommentar von MrCreeper2011 ,

Nope es geht nicht, auch mit der plugin.yml, habs nochmal veruscht ):

Antwort
von LudwigSchindler, 21

Bei main: fehlt der Doppelpunkt. Zeile 6

Kommentar von MrCreeper2011 ,

Ja, aber jetzt findet er die Klasse nicht xD

Kommentar von LudwigSchindler ,

Du musst dort auch auf Groß- und Kleinschreibung achten. Das "i" beim zweiten "Info" muss groß geschrieben werden, weil die Klasse auch groß ist.

Antwort
von MBgamer, 18

"invalid Plugin.yml"

"
28. in 'reader', line 5, column 1:
29. main me.mrcreeper2011.info.info
30. ^"

"could not find expected ':' "

also doch nicht alles wie im Video gemacht...

Kommentar von MrCreeper2011 ,

hää?!

Kommentar von MBgamer ,

Was "hää?!" ?!? In der plugin.yml fehlt hinter main der Doppelpunkt! Wer Englisch kann... (line 5 -> Zeile 5, could not find expected ':' -> Konnte benötigtes : nicht finden)

Und wenn er die Klasse jetzt nicht findet dann liegt das daran das du sie falsch angegeben hast. "package.Klasse"

me.mrcreeper2011.info -> Das package
Info -> Die Klasse

main:
me.mrcreeper2011.info.Info

Das i vom zweiten Info muss groß sein.
So schwer?

Kommentar von MrCreeper2011 ,

Der ":" war da, ich musste nur das I groß schreiben, mehr nicht

Kommentar von MBgamer ,

Gut, dann sollte ja jetzt alles funktionieren... außerdem war laut deinem Link oben kein : hinter "main", aber auch egal ;)

Keine passende Antwort gefunden?

Fragen Sie die Community