Frage von joeysfalsa, 76

In Excel, Welche Zellen Formel zum Rot Einfärben eines bestimmten Werts?

Hab eine Einfache Tabelle erstellt A2 bis A10 kann man Werte eingeben. Also Zahlen..

In B2 bis B10 genau so

und das setzt sich fort bis F

Die Eingegebenen Werte in den Zellen A / B /etc werden in Zelle G2 bis G10 zusammengezählt.

also addiert.

Jetzt ist es so , das die Addierten Zahlen in Zelle G immer Schwarz sind.

Nur möchte ich das ,wenn eine Bestimmte Summe X Überschritten wird - sich die Summe Fett Rot Färbt.

Wie mach ich das am besten. ?

Beispiel: A2 =100 B2 = 1200 C2 = 56,5 D2 = 0 Wert Null bis F2 = 0

Summe in Zelle G2 = 1356,5

Maximal zulässige Summe wäre aber nur 1300 - somit soll sich der Wert FETT und in ROT Färben und als 1356,5 ausgeben.

Das selbe Spiel für die Werte in A3 bis F3 und so weiter bis A10 und F10

Welche Formel muß somit in Zelle G2 bis G10 ?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von iMPerFekTioN, 29

So,

nach lesen deiner Kommentare da du ja scheinbar was wichtiges vergessen hattest, solltest du dir eine Hilfstabelle anlegen, in der du die Maximalen Werte definierst.

In A1 steht per Dropdown Menü ja deine Auswahl zur Verfügung, welches "Item" du auf den Maximalen Wert überprüfen möchtest.
In B1 hast du dann wohl den Wert definiert, bzw. ein Feld um diesen Wert einzutragen.

Auf diesem Feld startest du deine Bedingte Formatierung (Da du ja gemeint hast du weißt wie das geht, muss ich dir ja nicht erklären wie du da hin kommst :p)

Nehmen wir den Tabellenbereich H1:I10:

H1 = "Apfel"
H2 = "Auto"
H3 = "Noch ein Kriterium von dir"
H4 = "Noch ein Kriterium von dir"
H5 = "..."
H6 = "..."

So, in I1:I10 schreibst du die dazugehörigen Werte:

I1 = "10€"
I2 = "2000€"
I3 = "40€"
I4 = "50€"
I5 = "200€"
I6 = "35€"

So, jetzt machst du die Bedingte Formatierung auf der gewünschten Zelle und benutzt dann diese Formel:

=WENN(B1>SVERWEIS(A1;H1:I10;2;0)

Das reicht dann schon.

Grüße,

iMPerFekTioN

Kommentar von joeysfalsa ,

Das mit der Hilfstabelle für die Max Werte klingt sehr gut...

schon komisch das der Befehl immer "Server weist" heißt - nur der Nutzer nicht. :D

Werd ich sobald ich wieder am Arbeitsrechner bin mal umsetzten...

Kommentar von iMPerFekTioN ,

Naja, von SVEREIS "Server weißt" ist eher schlecht hergeleitet, Senkrechter Verweis passt da besser ;)

Kommentar von joeysfalsa ,

war der Richtige Tip. thx ;)

Antwort
von fserenade, 47

Einzufärbende Zellen anwählen, dann unter Formatierung die bedingte Formatierung auswählen.

Dort kannst du dann eingeben "grösser als Wert 1300" und das Feld rot färben bzw. Die Zahl rot färben.

Kommentar von joeysfalsa ,

Ahh o.k. und wie sage ich dem Teil , wenn ich über das Auswahl Menü in Zelle A1 die Möglichkeiten ändere=?

Siehe auch Beispiel von meinem letzten Kommentar

Kommentar von fserenade ,

Gut. Dann nimmst du ein zusätzliches Feld mit einer Formel, die den Preis bedingt. Also hinter dem Feld mit der Summe fügst du eine solche Formel ein: =WENN(UND(A1="Auto";A6>2000);1;WENN(UND(A1="Apfel";A6>20);1;0 Damit definierst du, dass die Zelle eine 1 erhält wenn der Preis für ein Auto über 2000 ist oder der Preis für einen Apfel über 20. Ansonsten eine 0. Und das Feld mit der Summe wird dann formatiert, wenn sich in der hinteren Zelle eine 1 befindet. Die Formel wird so nicht ganz stimmen. Probiers aus. Ich versuchs heute Abend, wenn ich zu Hause bin aus, dann kann ich dir die richtige Formel geben.

Antwort
von ernkie, 22

ein Denkanstoss für die Formel in der Bedingten Formatierung (Zelle G2)

=UND($A2="Apfel";$G2>1300)

mit der Formatierung Schrifft rot und fett


Antwort
von Deepdiver, 40

geh doch über die Bedingte Formatierung. Da kannst du alles eingeben.

Kommentar von joeysfalsa ,

Ja kenne ich, aber dort kann ich nur Färben wenn etwas bestimmtes eintrifft...

Oh Merke wieder mal das ich was wichtiges Vergessen habe zu erwähnen..
Die Zellen A1

Dort sind Namen Hinterlegt, welche ich über ein Auf klapp Menü auswählen kann.

Damit ändert sich aber auch die Max Summe die in Zelle G erreicht werden kann.

Beispiel:

In A1 steht zur Auswahl

Auto:

Motorrad

Apfel

Für den Wert Auto wären die 1356,5 im oberen Beispiel i.o
Aber für den Apfel, wenn ich diesen im Menü auswähle wäre er zu hoch und soll sich FETT Rot Färben.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten