Frage von Erothh, 76

Wienkann man in Excel mit WENN nur den z.B. MIttelwert berechnen, wenn eine andere Zelle N ergibt?

Hey,

mein Problem ist:

Ich habe eine Tabelle in der viele Werte stehen nun möchte ich nur den Mittelwert der Werte berechnen die den Wert N haben.

=WENN(Trimenon1!M:M="N";MITTELWERT(Trimenon1!H:H))

Also wenn in der Spalte M ein N steht möchte ich von allen Werten in Spalte H die ein N in der Spalte M haben den Mittelwert.

Wenn ich das so mache wie oben beschrieben bekomm ich den gleichen Wert raus als würde ich einfach =MITTELWERT(Trimenon1!H:H)) machen.

Ich hoffe ihr versteht mein Problem :)

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 59

Das Problem ist denke ich Trimenon1!M:M="N"

Das würde ich umschreiben zu

ZÄHLENWENN(M:M;"N")>0

Achso, du willst dann nur von den Zeilen, in denen in Spalte M ein "N" steht, den Mittelwert bilden. Das sollte auch kein Problem sein...

=MITTELWERTWENN(M:M;"N";H:H)

Die Tabellenreferenzierung auf Trimenon1 musst du noch hinzufügen.

Kommentar von Erothh ,

Top Danke!

Gleich noch eine Frage dazu kann ich das mit einer Art und verknüpfen? Also z.B. Wenn M:M & N:N & O:O = "N" ist dann den Mittelwert?

Kommentar von Suboptimierer ,

Probier mal MITTELWERTWENNS aus.

Kommentar von Erothh ,

Ok funktioniert alles soweit. Mein  Problem jetzt ist das es wohl kein MEDIANWENNS,MAXWENNS u.s.w gibt oder :( ?

Kommentar von Suboptimierer ,

Für solche Spezialfälle halte dich an Propaganjas Kommentar. Du kannst mittels Matrixformeln, die du mit Strg+Shift+Enter abschließt, Funktionen mit WENN kombinieren. =MEDIAN(WENN(...))

Mehrere Bedingungen verwirklichst du als UND-Verknüpfung, indem du die WENN-Bedingungen multiplizierst. Eine Oder-Verknüpfung bekommst du mit + hin.

In deinem Beispiel:

=MITTELWERT(WENN((C1:C6="N")*(A1:A6="N");B1:B6))
oder gleich:
=MITTELWERT((C1:C6="N")*(A1:A6="N")*B1:B6)



Kommentar von Suboptimierer ,

Der letzte Befehl geht komischerweise nicht. :/

Antwort
von Propaganja, 52

ich versteh die frage nicht, wenn N in den zellen steht? warum willst du von "vielen N's" den mittelwert berechnen? :D 

Kommentar von Erothh ,

Also ich habe Werte in einer Spalte. In der gleichen Zeile aber anderen Spalte steht N dafür das dieser Wert zustande gekommen ist ohne ein Medikament.

Jetzt möchte ich den Mittelwert aller Werte die kein Medikament bekommen haben. Verstanden^^?

Kommentar von Propaganja ,

ok

sagen wir mal spalte A steht entweder N oder nicht

die werte stehen in spalte B, 

dann müsste der mittelwert so berchnet werden
{=MITTELWERT(WENN(A1:A6="N";B1:B6))}

Kommentar von Erothh ,

1a das hilft auch :D Kann ich das jetzt noch verunden ? So wie ich oben gefragt hatte? Wenn M:M & N:N & O:O = "N" dann BLABLA

Kommentar von Erothh ,

Hab von oben : 

=MITTELWERT(WENN((C1:C6="N")*(A1:A6="N");B1:B6))
Kommentar von Propaganja ,

klappts oder brauchste noch hilfe?

Kommentar von Erothh ,

Jaein. 

Funktioniert das eventuell bei vielen Werten nicht? Wenn ich das z.b. mit ANZAHL mache ist gibt er mir genau 1 Wert weniger als ich habe. 

Und mit dem Mittelwert wirkt es auch so als würde min 1 Wert ignoriert werden. 

Wenn ich das jetzt so in einem neuen Excel Dokument teste geht es ohne Probleme so wie es soll.

Vllt liegt es einfach an der Größe (hab ca 10.000 Zeilen).

Kommentar von Propaganja ,

die größe sollte nicht das problem sein

also du kannst auch in den funktionen die ganze spalten ansprechen mit z.B.: A:A oder B:B

oder du bennennt die genauen zeilenzahlen (von .. bis) z.B.: A1:A10001 oder B1:B10001 

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten