Frage von Spinbad123, 44

In Excel eine Auswahl erstellen?

Hallo zusammen,

ich habe eine Liste, bestehend aus 3 Faktoren. KW ( Kalenderwoche ) Tour und der Plan.

Wer jetzt vermutet, dass es sich um einen Schicht bzw. um einen Arbeitsplan handelt, hat Recht.

Nun würde ich gerne ein Feld haben, wo ich z.B.: KW 31 eintrage und der mir dann die Tour + die Woche dahinter anzeigt.

Kann mir jemand helfen wie ich das in Excel mache?

Ggf. auch per VBA.

Vielen Dank

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 31

Hast du es schon einmal mit dem SVERWEIS oder INDEX + VERGLEICH probiert?

Noch mehr würde sich ein (Auto-)Filter anbieten.

VBA halte ich für die Aufgabenstellung nicht geeignet.

Kommentar von Spinbad123 ,

Da ich null Plan davon habe werde ich mal nach deinen Vorschlägen googlen. Vorab schon mal vielen Dank für deine Tipps :D

Expertenantwort
von DeeDee07, Community-Experte für Excel, 23

Eine Kategorie (in diesem Fall KW) in mehrere Spalten zu schreiben ist datentechnisch nicht sehr vorteilhaft, wenn auch platzsparend.

Ich würde dafür nur eine Spalte verwenden und dafür die sich wiederholenden Touren kopieren, dürfte kein großer Aufwand sein (einmalig).

Dann kannst du es, wie Suboptimierer vorschlägt, mit SVERWEIS bzw. INDEX+VERGLEICH lösen.

Falls du auf die jetzige Darstellung bestehst, kannst du in einer verschachtelten WENNFEHLER-Funktion alle Spalten nacheinander mit SVERWEIS prüfen, etwa so

=WENNFEHLER(SVERWEIS(Bezug_auf_KW-Spalte1);WENNFEHLER(SVERWEIS(Bezug_auf_KW-Spalte2;usw...))

Die Formel wird halt unübersichtlich.

Kommentar von Spinbad123 ,

Ihr seit in der tat Community-Experten...


Ansich ist es mir egal, wie das ganze Aussieht. Da ich hinterher nur die KW eingeben möchte sehe ich den rest eh nicht.


Bsp.:  

Ich will nur die KW eingeben

51 und dann soll mir die Tour 1 angezeigt werden, Dann gebe ich noch die 20 und 24 an und mir wird die Tour 5 und 9 gezeigt.


Es müssen nichtmal meherer angezeigt werden.


Vielen Dank


Kommentar von DeeDee07 ,

Leider lieferst du weder in der Frage noch auf dem Screenshot irgendwelche Hinweise auf Zellbezüge, somit kann man dir keine auf deine Umstände passende Formel liefern.

Nehmen wir an, KW steht in Spalte A, Tour in B, Mo in C usw. (ab Zeile 1, 52 Zeilen umfassend.

Nehmen wir an in A55 trägst du die gesuchte KW ein. Dann lautet die Formel in B55 für die entsprechende Tour:

=SVERWEIS($A55;$A$1:$I$52;2;FALSCH)

Diese Formel sucht den Wert aus A55 in A1:A52 und gibt, wenn es ihn gefunden hat, den entsprechenden Wert der 2. Spalte im Bereich A1:I52 wieder.

Für den entsprechenden Wert aus Spalte C passt du den Spaltenindex (oben fettgedruckt) in der Formel an (3 statt 2):

Pro-Tipp: Um die Formel nach rechts kopierbar zu machen, so dass sich der Spaltenindex dabei entsprechend anpasst, verwendest du die Funktion SPALTE:

=SVERWEIS($A55;$A$1:$I$52;SPALTE(A2);FALSCH)

Das spart die Arbeit, jede Formel manuell anpassen zu müssen.

Keine passende Antwort gefunden?

Fragen Sie die Community