Frage von nadidom, 76

Wie kann ich in einer Excel-Adressliste Dublette und Original löschen?

Für meine Excel-Adressliste benötige ich eine Formel oder Funktion, die sowohl Namensdubletten als auch das -Original löscht. Übrig bleiben sollen also nur die Namen, bei denen es keine Dubletten gab. Verglichen werden sollen die Spalten "Vorname" und "Nachname".

Bsp:

  • Zeile 1, Spalte Vorname: "Sepp", Spalte Nachname "Huber"

  • Zeile 2, Spalte Vorname: "Alex", Spalte Nachname "Meier"

  • Zeile 3, Spalte Vorname: "Karin", Spalte Nachname "Müller"

  • Zeile4, Spalte Vorname: "Alex", Spalte Nachname "Meier"

In diesem Fall soll Zeile 2 und Zeile 4 komplett gelöscht werden. (Ich habe eine Excel-Version von 2013)

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 58

Markiere doch vorher die zu löschenden Zeilen in einer Extra-Spalte und führe darauf einen Filter aus:

=ZÄHLENWENN(A:A;A1)>1
Kommentar von nadidom ,

Da die Excel-Liste über 10.000 Adresszeilen lang ist, kann ich die zu löschenden Zeilen nicht händisch markieren. Excel müsste für mich die doppelten Werte selbst erkennen und löschen.

Kommentar von Suboptimierer ,

Du musst die Formel nur in einer Zelle eingeben (der obersten).

Drücke dann: 

  • Strg + c
  • Strg + g → Inhalte... → letzte Zelle → OK
  • Strg + Shift + ↑
  • Strg + v
Antwort
von pugggi, 58

Wieso soll das Original auch gelöscht werden? Dann gibt es doch gar keinen Alex Meier mehr....  Kannst du das Anwendungsgebiet ein wenig mehr erläutern?

Kommentar von nadidom ,

Genau so ist das auch gemeint. Es soll also keinen Alex Meier mehr geben in der Liste. Hintergrund ist folgender: Ich habe eine Adressliste und eine "Negativ-Adressliste" in eine Excel-Liste zusammengeführt. Die Personen, die in der "Negativ-Adressliste" auftauchen, sollen keinen Brief erhalten. Deshalb muss also Alex Meier komplett entfernt werden, weil er in der Negativliste auftaucht und auch in der Adressliste, deshalb gab es ja die Dublette. Ich hoffe, ich konnte das verständlich formulieren?!

Kommentar von pugggi ,

Ah ok.

Also du kannst neben die Tabelle eine Hilfsspalte setzen und da die Formel laufen lassen:

(A= Vorname, B= Nachname; Bereich bei mir 2-100 muss auf deine Tabelle angepasst werden, je nachdem wie viele Zeilen du hast)

=WENN(ZÄHLENWENNS($A$2:$A$100;A2;$B$2:$B$100;B2)>1;"x";"")

Anschließend kannst du die Spalte filtern und nur x anzeigen lassen. Die kannst du dann löschen.

Es gibt auch die Möglichkeit da ein Makro für zu schreiben aber mit der Formel wird es auch schon gehen. Sonst sag Bescheid dann bastel ich dir was.

Kommentar von nadidom ,

Vielen Dank! Ich werde versuchen, die Formel anzuwenden und gebe morgen Bescheid.

Antwort
von FGO65, 51

Dafür gibt es keine Funktion oder Formel, müsste mittels VBA programmiert werden

Kommentar von Iamiam ,

aber mit fümpf Aktionen ist es erledigt: viieel kürzer als ein Makro schreiben!

  1. obige Formel schreiben
  2. über alle Zeilen kopieren
  3. Formelspalte zu Wert umsetzen
  4. danach sortieren
  5. alle 2en gesammelt löschen

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten