Frage von Ahzumjosh, 33

In Excel > Zeichen in Rechnung übernehmen?

Hallo alle zusammen,

ich habe eine Frage zu Excel, die Zahlen und Zellen dienen nur als Beispiel:

In A1 steht: <25 (Es kann aber auch >25 oder nur 25 sein)

In B1: 100

Nun will ich in C1 das Ergebnis aus A1/B1 berechnen und dabei, wenn in A1 "<" steht auch in C1 vor dem Ergebnis ein "<" stehen haben, wenn in A1 ein ">" steht auch in C1 ein ">" und wenn nichts vor der Zahl in A1 steht soll auch nichts vor dem Ergebnis in C1 stehen. Wie lässt sich sowas realisieren? Meine Ideen haben bisher alle nicht funktioniert.

Ergebnis von <25/100 soll also <0,25 sein usw. ...

Ich bin über jede Hilfe dankbar!!

LG

Expertenantwort
von Oubyi, Community-Experte für Excel, 20

Ich finde die Aufgabe interessant, auch wenn ich den Sinn nicht sehen kann. Deshalb habe ich mich auch noch dran gesetzt und eine Lösung gefunden. Die ist nicht besser als die anderen, nur anders und hat evtl. den Vorteil, dass es egal ist welches Zeichen links von der Zahl steht (solange es nur EINES ist).

=WENN(ISTZAHL(LINKS(A1;1)*1);A1/B1;LINKS(A1;1)&WECHSELN(A1;LINKS(A1;1);"")*1/B1)

Antwort
von Funfroc, 33

Hallo,

ich verstehe den Sinn dahinter noch nicht... daher mal ins Blaue:

=WENN(LINKS(A1;1)="<";"<"&WERT(RECHTS(A1;2))/B1;WENN(LINKS(A1;1)=">";">"&WERT(RECHTS(A1;2))/B1;A1/B1))

LG; Chris

Edit: Ansatz von Shitz0vran ist sinnvoller, weil deckt Eventualitäten (z.B.: nur eine Ziffer nach <>) besser ab.

Antwort
von ShitzOvran, 29

=WENN(ODER(LINKS(A1;1)=">";LINKS(A1;1)="<");LINKS(A1;1)&(WERT(RECHTS(A1;LÄNGE(A1)-1))/B1);A1/B1)

... ungetestet, sollte aber so klappen

Antwort
von dkilli, 11

Ich verstehe deine Frage nicht. Wann ist etwas Klein, Groß oder Normal? Gib mal Werte an.

Antwort
von Ahzumjosh, 18

Hat funktioniert, vielen Dank euch beiden!! :)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten