Frage von nothing1990, 40

In der Zelle B2 soll "10%" automatisch eingetragen werden, wenn in A1 die Zahlen 26,27,28,29,30 eingetragen werden (mit Hilfe der WENN-Funktion. Wie geht das?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von daCypher, 40

=WENN(UND(A1>=26;A1<=30);"10%";0)

bzw. statt "10%" kannst du auch 0,1 reinschreiben und in der Zelle B2 die Formatierung auf "Prozentzahl" stellen.

Kommentar von FireSire ,

Wollt ich ihm auch erst raten, aber in dem Fall sind auch alle reellen Zahlen zwischen 26 und 31 drin und die wollt er ja eventuell nicht ^^

Kommentar von daCypher ,

Ja. wenn die 10% wirklich nur bei natürlichen Zahlen da stehen soll, dann muss man das "Und" noch erweitern mit GANZZAHL(A1)=A1. So wie es Suboptimierer in seiner Antwort geschrieben hat.

Expertenantwort
von Ninombre, Community-Experte für Excel, 27

Klassisch mit einer ODER Bedingung in der Wenn-Formel:

=WENN(ODER(A1=26;A1=27;A1=28;A1=29;A1=30;A1=31);"10%";"")

oder um den Ansatz daCypher aufzugreifen die lückenlose Zahlenkette nutzen:

=WENN(UND(A1>=26;A1<=31;REST(A1;1)=0);"10%";"")

Mit Rest A1/1 = 0 soll geprüft werden, dass es eine ganze Zahl ist, denn auch 26,5 wäre ja zwischen 26 und 31

Kommentar von Ninombre ,

s. Beitrag von Suboptimierer: Man kann Deine Frage auf zwei Varianten verstehen: Soll da die Zahl 10% stehen oder willst Du das Ergebnis von A1 * 10 % rechnen? Ich schreib 10%, Suboptimierer rechnet die 10% von A1 wenn es ein Wert 26 bis 31 ist.

Kommentar von Suboptimierer ,

Ich rechne nicht 10% von A1.
Du kommst wieder mit den Grenzen durcheinander ;)

Kommentar von Ninombre ,

ahaha - ich hab die erste Variante mit den 10%*(ganzzahl).. nicht richtig angeschaut, wird ja immer nur mit wahr/falsch gerechnet.

Heisst für den Fragesteller, dass er vier Varianten kennt, wie man 10% reinschreibt und keiner die Frage anders verstanden hat.

Kommentar von Suboptimierer ,

>26 und <31, sonst topp!

Antwort
von MrRayman, 37

Welchen Programm nutzt du?

Mit Excel (oder ähnichen Programmen) funktioniert es mit verschachteten WENN-Funktionen. Also diesen Code weiter fortführen und in die B2 Zeile eintragen. Wichtige auf Klammersetzung achten. Ist leider recht aufwendig, gibt bestimmt bessere Lösungsansätze

=WENN(A2=26;WENN(A3=27;WENN(A4=28;0,1)))

Kommentar von nothing1990 ,

Ich nutze Excel 2016

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 28
=10%*(GANZZAHL(A1)=A1)*(A1>=26)*(A1<=30)

Als WENN-Funktion:

=WENN(UND(GANZZAHL(A1)=A1;A1>=26;A1<=30);10%;0%)
Antwort
von FireSire, 36

Ich glaub, das wirtschaftlichste ist ne verschachtelung von If und Or.

Also... =IF(OR(A1=26,A=27, ~),10%,"Fehler")

Kommentar von nothing1990 ,

Ich habe es gerade ausprobiert, es hat irgendwie nicht funktioniert. "26,A" hinterlegt das Programm grau und meldet es als ungültig...???

Kommentar von daCypher ,

In der englischen Excel-Variante benutzt man Kommas zum Trennen der Argumente. In der deutschen Variante musst du dafür ein Semikolon nehmen und auch deutsche Begriffe, also statt IF nimmst du WENN und statt OR nimmst du ODER

Kommentar von nothing1990 ,

Ich bin gerade irgendwie nicht dahintergekommen, dass es englisch sein könnte. Dann klappt es auch. Super, Danke!

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten