Frage von ThunderSun, 66

In Excel einen Bereich mit Wenn in L5:L66 "Meier" durchsuchen, dann addiere das Std-Feld(13:30) (Q5:Q66). Leider bekomme ich immer Null als Ergebnis - was tun?

Ich habe herausgefunden, dass es nicht funktioniert, da ich hinter Meier noch andere Dinge stehen habe, z. B. Meier Reparatur oder Meier Kundendienst. Was muss ich dann in die Formel eintragen, damit er alle Meier-Summen findet und addiert? Mit "Meier*" funktioniert es leider nicht...

Antwort
von Herb3472, 25

Ich denke, Du musst deine Aufgabenstellung in mehrere Teilaufgaben aufspalten.

Zuerst benötigtst Du einmal isoliert die Namen. Die musst Du aus der Spalte "Meier Kundendienst" etc. herausfiltern und am besten in einer eigenen Spalte abspeichern, von der aus Du sie dann abfragen kannst.

Wenn hinter allen Namen noch ein  Leerzeichen (und danach eventuell auch noch ein anderer Text wie "kundendienst") nachgestellt ist, funktioniert das Abtrennen des Namens mit folgender Formel:

=LINKS(A2;SUCHEN(" ";A2;1))

Die Formel funktioniert jedoch nur dann, wenn der Text mindestens ein Leerzeichen enthält, ansonsten erscheint die Fehlermeldung #Wert!

Wenn es auch Einträge gäbe, bei denen nur der Name ohne Leerzeichen eingetragen ist, müsste man die Formel erweitern.

Eine Anleitung zum Aufteilen von text findest Du hier:

https://support.office.com/de-de/article/Aufteilen-von-Text-in-Spalten-mithilfe-...


Expertenantwort
von Ninombre, Community-Experte für Excel, 36

Wenn ich das richtig verstanden habe, steht in L nicht nur "Meier", sondern ein Text wie "Meier Kundendienst". Damit funktioniert die Abfrage auf den Inhalt der Zelle nicht, da musst Du auf den relevanten Teil des Zellinhalts abfragen. In der Hoffnung, dass der Name wirklich immer am Anfang steht, wäre das eine Lösung

=SUMMENPRODUKT((LINKS(L5:L66;5)="Meier")*Q5:Q66)

Die Anzahl der Stellen, die mit Links abgegriffen werden, muss der Anzahl des Namens entsprechen - bei Meier halt 5.


Wenn die Namen neben dem Summenfeld stehen, kannst Du das Anpassen sparen und in der Formel auf das Namensfeld gehen: (bspw. D1)


=SUMMENPRODUKT((LINKS(L51:L66;LÄNGE(D1))=D1)*Q5:Q66)


Kommentar von ThunderSun ,

Das probiere ich gleich mal. Funktioniert das denn auch, wenn ich 2 unterschiedliche Namen mit der gleichen Anzahl von Buchstaben habe?

Kommentar von Herb3472 ,

Mit der gleichen Anzahl von Buchstaben funktioniert das. Wenn die Namen auch verschieden lang sein können, müsstest Du den Text z.B. ab dem Leerzeichen abschneiden:

=WENN(LINKS(A1;FINDEN(" ";A1)-1); wahr; falsch)

Die Formel sucht nach dem unter Anführungszeichen stehenden Zeichen (das kann ein x-beliebiges Zeichen sein) und überprüft nur den davor stehenden Textteil.


Kommentar von Herb3472 ,

Sorry, die Formel ist nicht vollständig. Korrektur bzw. Ergänzung folgt gleich.

Kommentar von Ninombre ,

Ja, das funktioniert unabhängig vom Namen. Die Formel links(A1;5) sagt einfach, dass vom Text in der Zelle A1 die 5 Zeichen von links her betrachtet werden. Auf diese Zeichen erfolgt dann die Prüfung, ob "Meier" drin steht. Da könnte auch nach einem beliebigen anderen Namen gesucht werden. Die Anzahl der Zeichen bei "links" muss nur zur Länge des Namens passen. Wenn man Müller sucht, muss man ja 6 Zeichen betrachten, sonst kann der Textausschnitt ja nie "Müller" sein, sondern nur "Mülle" (bei 5 Zeichen)

Kommentar von ThunderSun ,

Das klappt nicht, schade... Dann bekomme ich #WERT! angezeigt.

Kommentar von ThunderSun ,

Ich habe eben probiert, einen Screenshot zu senden, funktioniert aber leider nicht :-(

Antwort
von Herb3472, 28

Wenn ich Dich richtig verstanden habe, liegt Dein Hauptprobelm in der Summenbildung der Arbeitszeiten.

Es gibt im Internet jede Menge Lösungsansätze und Beispiele Zum Thema "Arbeitszeiterfassung":

Vielleicht hilft Dir das hier weiter:

http://www.office-loesung.de/ftopic110005_0_0_asc.php

Kommentar von ThunderSun ,

Danke für den Tipp, aber das hilft mir nicht so ganz weiter, da ich eine recht umfangreiche Tabelle mit diversen Formeln habe, die ich um diese Abfrage erweitern muss....

Expertenantwort
von Oubyi, Community-Experte für Excel, 31

=SUMMEWENN(L5:L66;"Meier";Q5:Q66)

Das Formelfeld formatieren als:
[h]:mm

Klappt es?

Kommentar von ThunderSun ,

Leider nicht, ich erhalte das Ergebnis 0:00, obwohl das leider nicht stimmen kann :-(

Kommentar von Oubyi ,

Tippe mal in z.B. L10 Meier und schreibe in Q10 2:30.
Dann muss im Formelfeld 2:30 erscheinen oder 0,104166667.
Wie ist die Formelzelle formatiert?

P.S.: Muss jetzt leider zur Arbeit, aber die anderen Experten hier werden Dir sicherlich weiterhelfen.

Kommentar von Suboptimierer ,

Vielleicht hilft:

=SUMMEWENN(L5:L66;"*Meier*";Q5:Q66)

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten