Frage von David2334, 64

Ich habe ein Problem mit meiner Excel Tabelle. Ich möchte die Zahl und das Wort gleichzeitig gezählt bekommen. Bsp: 8DI Meine Var oben soll die Zeilen mal...?

Also meine Tabelle sieht ja wie folgt aus im Bild. Ich möchte meine Variable oben also "Stück", die Zeile B7 mal nehmen. Problem bei der Sache ist allerdings, wie bekomme ich die DI mit der Zahl vorne gerechnet, das rechts in der Spalte z.B diese 16DI stehen und die restlichen DO,AIPT usw ausgrenzen kann.

Expertenantwort
von Oubyi, Community-Experte für Excel, 27

Also ICH werde nicht schlau aus Deiner Beschreibung. Mit B7 kann ich erstmal nichts anfangen, da Du die Spaltenköpfe nicht mit in Deinen Screenshot genommen hast. Und was ist dann "rechts in der Spalte"? Und 16DI kannst Du auch nicht mal nehmen, höchstens die 16. Willst Du das?
WENN! vor dem 16DI max. eine zweistellige Zahl steht und davor ein Leerzeichen, bekommst Du die 16 so aus einem String in A1:

=TEIL(A1;FINDEN("DI";A1)-2;2)*1

Versuche mal Dein Vorhaben besser zu beschreiben. WAS soll wo durch eine Formel eingetragen werden?

Kommentar von Iamiam ,

ich hab auch nur auf Verdacht gearbeitet!

Expertenantwort
von Iamiam, Community-Experte für Excel, 26

weiß nicht, ob ich Dich richtig verstanden habe, deshalb versuch ich zu erklären, was ich machen will: [da Du von Zeile z sprichst, nehme ich an, dass die Stückzahl in Zeile 3 steht und der Bezeichnungsteil in $B5.

Ist die graue Zelle mit Einträgen darunter Spalte A? gehe mal davon aus)

=finden(B$4;$A7;1) liefert die Position von DI, ...-3 die des Leerzeichens links neben der Zahl (wenn ich mich auf das Leerzeichen beziehe, können auch dreistellige Zahlen und mindestens zweistellig! verarbeitet werden. Kommen auch 1-stellige vor, darf man nur -2 nehmen und kann dann 1- und 2-stellige Zahlen verarbeiten (Du siehst, was man alles berücksichtigen muss!)


=Teil($A7;finden(B$4;$A7;1)-3;3) liefert den Abschnitt mit der Zahl (noch als Text)
=TEIL($A7;FINDEN(B$4;$A7;1)-3;3)*B$3
multipliziert mit dem Faktor in Zeile 3, dadurch macht xl aus dem Text eine Zahl
Wennfehler(...;0) unterdrückt nichtzutreffende Angaben und macht 0 daraus
Kannst anstatt 0 natürlich auch jedes andere Zeichen anzeigen oder aber -wenn eine weitere Auswertung als Zahl benötigt wird,

das Benutzer-definierte Format
#;[rot]-#;[magenta]°
verwenden, das die Null als unauffälligen violetten °-Kringel stilisiert.
Benutzerdefiniert: Strg+1, Karte Zahlen, in Liste Benutzerdefiniert wählen (das nicht verwechseln mit "bedingtes Format"!)

Kommentar von Iamiam ,

Die Formel ist nach oben, unten und rechts kopierbar (deshalb der violette °-Kringel), also können alle Bezeichnungsteile abgefragt werden

Kommentar von Iamiam ,

Ach so, Dein Beipiel heißt 8DI. Dann nur 1-und 2-stellige Zahlen:
=Wennfehler(TEIL($A7;FINDEN(B$4;$A7;1)-2;2)*B$3;0)

Übrigens: Finden beachtet Groß/klein. sill auch Di, dI oder di gleichermaßen ausgewertet werden, dann anstatt Finden die Formel SUCHEN verwenden (exakt gleiche Syntax)

Kommentar von Iamiam ,

auch längere Zahlen sind möglich. Nur auf Anfrage.

Kommentar von Iamiam ,

weils mich gereizt hat, hab ich das jetzt doch mal gemacht für ein 15-stelliges Ergebnis.

  • in A8 abweichend  abc 123DOxy z 
  • in C3 als Faktor nur 3 (wegen der Übersichtlichkeit der Ergebnisdarstellung) und
  • in C4 Dein DO

Formel in:

C8: =WENNFEHLER(TEIL(WECHSELN($A8;" ";" ");FINDEN(C$4;WECHSELN($A8;" ";" ");1)-15;15)*C$3;0)

Ergebnis 369.369.369.369.369

Was hab ich gemacht? Lediglich A8 durch Wechseln von einem Leerzeichen gegen derer 14 so erweitert, dass die größtmögliche Zahl noch erfasst wird (xl rechnet nur auf 15 Stellen, mind. eine ist ja schon die Zahl selbst, also reichen 14 weitere) und die Position/Länge des als Zahl auszuwertenden Strings angepasst. Fertig! (Weitere Leerzeichen im Text von A8 stören übrigens nicht, egal wo, nur zwischen Zahl und Suchargument darf keines sein. Wenn doch, muss in einem weiteren Wechselschtitt ein LeerzeichenDO gegen das reine DO ausgetauscht werden! Mischformen gehen nicht)

Wegen der Multiplikation mit C$3 kommt da eine formatierbare Zahl raus und kein Text.

Antwort
von Britzcontrol, 18

Die Antwort von noname68 kann nicht unwidersprochen bleiben.
Siehe Bildschirmkopie

Gruß aus Berlin

Antwort
von excelentoDOTde, 36

Ich denke hiermit könnte man sich weiterhelfen:

{=SUMME(WENN(ISTTEXT(A1:A6);1;WENN(ISTZAHL(A1:A6);1;0)))}

(Ungetestet)

Kommentar von Oubyi ,

Was willst Du damit erreichen?
Ich sehe da keinen Unterschied zu:
=ANZAHL2(A1:A6)
und was das mit der Fragestellung (die ich allerdings auch nicht verstehe) zu tun hat, sehe ich nicht.

Antwort
von noname68, 34

"anzahl2"  zählt die nicht-numerischen werte, "anzahl'" die numerischen.

beides zusammen in einer zelle geht aber nicht


Kommentar von Oubyi ,

"anzahl2"  zählt die nicht-numerischen werte

Das ist falsch.

Kommentar von Iamiam ,

als Eselsbrücke: Anzahl2 zählt 2erlei ! (Zahlen und Texte), Anzahl nur eines: Zahlen

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten