Frage von MasterTime67434, 16

Ich habe ein Plugin geschrieben und es ist nichts falsch nur der Server erkennt nicht das plugin kann mir einer helfen?

Antwort
von LudwigSchindler, 14

Schick mal bitte den Fehler in der Konsole und die plugin.yml auf hastebin.com. Wahschreinlich hast du es (wenn du es überhaupt gemacht hast) falsch eingerückt.

Antwort
von Atomtoasty, 12

Ist die Plugin.yml richtig?

Kommentar von MasterTime67434 ,

Ich kann sie dir schicken aber erst um 14 Uhr muss heute noch in die schule

Kommentar von MasterTime67434 ,

name: Daten
version: 1.0
author: MasterTime67431
main:Daten.Daten
commands:
info:
description: Zeigt Server Infos an

Kommentar von Atomtoasty ,

Fehlt da nicht eine CMD-Syntax?

Antwort
von MegaMann1234, 12

Wenn du mir mal die Fehlermeldung senden könntest

Kommentar von MasterTime67434 ,

Ich habe keine Fehlermeldung in der Konsole gefunden ich werde mal genau gucken! Dann schick ich sie dir

Kommentar von MasterTime67434 ,

[14:26:13] [Server thread/ERROR]: Could not load 'plugins/Infos.jar' in folder 'plugins'
org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:162) ~[craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:289) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at org.bukkit.craftbukkit.v1_8_R3.CraftServer.(CraftServer.java:251) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at net.minecraft.server.v1_8_R3.PlayerList.(PlayerList.java:69) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at net.minecraft.server.v1_8_R3.DedicatedPlayerList.(SourceFile:14) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:179) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-18fbb24]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_66]
Caused by: org.yaml.snakeyaml.scanner.ScannerException: while scanning a simple key
in 'reader', line 4, column 1:
main:Daten.Daten
^
could not find expected ':'
in 'reader', line 5, column 1:
commands:
^

Kommentar von MegaMann1234 ,

dein Plugin heißt Infos.jar?

Kommentar von MegaMann1234 ,

du hast ein Fehler in der Plugin.yml.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten